Yesterday I was playing on one of my Minecraft worlds. After a few minutes, my PC froze and nothing on the screen would move. After about 40 minutes, my screen was completely frozen and I decided to force my PC to shut down. When I started Minecraft again, my world had disappeared off the list. I then went on the "%appdata%" files, under ".minecraft" and "saves," and saw my world in the list! How can I get the world file shown in that folder to appear in the list of worlds in the game?

  • 1
    Your file got probably corrupted because it didn't save correctly. I must say you're quite unlucky to have this happen. I did the same thing a few times, and never ended up losing a world. Unfortunately, I'm not very good at solving problems like these. I might do a bit of research and see what can be done tomorrow. – Quijibo May 16 '19 at 19:21

After a LOT of messing around with the save files, I found out a few things:

  • Minecraft does not detect a file that is just there without any data as a save file
  • The world will appear in-game only it it contains the level.dat file with certain data

    • There must be a Data storage with a version tag with the value 19133
  • You can have whatever other junk files you want there, I even tried creating files with names and data that made no sense, and it still worked

I managed to launch a world that looked like this:


It turned out to work as a brand new world.

So make sure your save file contains this data. I used NBTExplorer for accessing and editing the .dat file.

| improve this answer | |

If the data isn't there, it doesn't exist. You could try file recovery tools like Revuva, but I doubt that that helps. The files were probably not saved at all, because your computer lagged too much for autosave or because of a different problem.

| improve this answer | |
  • Well, first of all, the data IS there, as it is in the .minecraft folder. Minecraft saves data while running, so the data was probably also saved, so it's something like constant auto-saving. Also, the most likely problem is the file not being saved correctly and becoming corrupt. – Quijibo May 16 '19 at 19:18
  • 1
    Oh, I misread the question, I thought he said it was NOT there. In that case I would recommend replacing parts of a functioning world one by one with parts of the broken world until it breaks, that way you know which part is responsible. And if it still works afterwards, it was just a missing file and you have a working world again now. – Fabian Röling May 17 '19 at 4:25
  • Now that's more like it :) – Quijibo May 17 '19 at 8:50
  • If you haven't downvoted my answer yet, please do, then I can get the "peer pressure" badge. :D – Fabian Röling May 17 '19 at 14:52
  • I already downvoted this one, but if you want the badge so bad I don't mind sacrificing a point of reputation on one of your other -2 vote posts :D – Quijibo May 17 '19 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.