0

It's been a while since I last played, so I tried to go back to it and play it (i'm using Mac) and it won't open. No error sign or anything appears, the icon will do one jump in my tool bar and then nothing happens. I've updated Java, I tried reinstalling Minecraft, I took everything out of the folder and kept my saves on my desktop, and just tried starting the game, but obviously I can't start the game, so that didn't do anything. I'm looking over the native log and it's kind of vague, at the end it says:

Native update needed--We need to update!

I don't know how to update it since it can't open though.

  • Please provide what version of iMac you are trying to play on. – GoneBoyGone May 18 at 8:56
  • Try 1.12.2, 1.13 has many issues. – Fabian Röling May 18 at 9:09
  • Or try 1.14, seeing as it is the newest one. – GoneBoyGone May 18 at 16:58
  • i would if i could but the Minecraft app wont even open so i can't really start the game at all to change its version – DoodleSnoop May 22 at 4:00
-1

It could mean to update your iMac (such as to El Capitan or High Sierra (which are both free updates by the way)) as it is out of date. Native usually means on your device, so this is probably the way to head. :)

  • i just updated after you commented this but it didn't change anything, but i'll check if there's anything else to update, thank you! – DoodleSnoop May 22 at 4:01
  • If all else fails, you could try to reset your PC? But that’s ridiculous, as literally everything would be gone. You could make backups, so not everything is gone? There might be some missing LaunchDaemons or Services or something in your PC, so if you’re sure, then reset it, but make sure to have backups, as this might not work (it probably would though)! – GoneBoyGone May 22 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.