I purchased Uncharted 3 about four days ago and am experiencing a very strange glitch. In the desert, inside the ghost town when we encounter several people shooting at us including a Sniper and Drake says that he can't do this anymore, right as Salim appears on horseback, the moment the cutscene should trigger, it is not.

The horse that Salim is on is stuck in the running animation in front of the stone that Drake takes cover behind and not moving.

The horses and characters are transparent and I can go through them. I did some exploration and glitched my way outside the settlement, where the map seems to end abruptly and buildings are half complete.

I have not tried jumping off the edge of the map, which shows gray area. The characters are still chanting and Drake is still playable.

Has anybody else experienced this glitch? And if so, is there a way past it?

  • I haven't experienced the glitch, but you can always reset the chapter or reload to the last checkpoint and try to avoid it next time. – Ivo Flipse Nov 12 '11 at 12:40

Yeah, I had the same thing. Just reboot the whole PS3 and it's fine.

  • Yeah, I solved this myself with some digging through Google. Led me to the Naughty Dog forum. Should have checked there first. Thanks! – Purag Nov 13 '11 at 6:33

This happened to me as well. I restarted the checkpoint and that didn't help. Then I let my PS3 cool overnight and it was fine then.

I recommend you to let your PS3 rest if this happens to you and it should be alright. =)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.