2

I've installed NFS MW 2005, but unfortunately it's impossible to play because of weirdly flickering screen with randomly and quickly appearing and disappearing horizontal stripes. It's difficult to capture this screen state as taken screenshots don't showcase this issue, but here is a photo of it:

enter image description here

Any idea what might be the issue?

I've tried updating NVidia GPU Drivers, but to no avail.

Config:
Laptop: MSI GE62 2QE Apache;
CPU: i7-4720hq;
GPU: GTX965M, 2GB;
RAM: 16 GB;
OS: Windows 10 64-bit, v. 1803;
NVidia driver version: 430.86
Directx: 12

  • Looks like a corrupted installation. Have you tried reinstalling the game? – XtremeBaumer May 28 '19 at 13:22
  • If screenshots don't show the artifacts, it may not be a software issue. Would a GPU artifact show up on a screenshot? – Roijan says reinstate Monica May 28 '19 at 13:28
  • @XtremeBaumer Yes, I've reinstalled it a couple of times – Overpass May 28 '19 at 13:38
  • @RoijanEskor But how come in this case there are no similar issues in all possible other use cases? – Overpass May 28 '19 at 13:39
1

Seems that running the game with the discrete graphics card only instead of system default mode which uses both Intel HD 4600 and Nvidia GTX965M did the trick.

| improve this answer | |
  • 1
    How do you do that? – Sumit Oct 13 '19 at 6:48
0

Set Vsync on, get to the settings screen, push 2 for advanced settings then push vsync on.

| improve this answer | |
New contributor
Nynke De Jong is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.