I'm playing Stellaris. The tutorial AI has been repeatedly (literally non stop) telling me to create sectors.

There is a Planets & Sectors menu as part of the main menu bar (it's even mapped to F4). It does not contain a "create sector" or "split into setors" or any such sort of UI element.

repeated calls from tutorial ai to create sectors, no create sectors button

I've looked long and hard through the UI, and nothing solves this issue

I've tried clicking on outside the menu onto solar systems while the Planets & Sectors menu is open, and I've tried unfolding the only sector I have and clicking everywhere within that.

I get taken to different other parts of the game. This planet, that leader, my empire tab, etc. etc. etc... nothing is meant as a create sector button.

I've also dug up old screenshots in this thread: https://steamcommunity.com/app/281990/discussions/0/357286119102514045/ old interface with "Create new Sector" button

In which you can see a "Create new Sector" button, but the interface has clearly changed since then.

1 Answer 1


As shown in this dev diary, starting in version 2.3 the option to form a sector is located in the planet window. The button has the "three hexes" sector icon and a plus sign, like so:

enter image description here

This will create a new sector centered on the chosen system that includes all other systems within four jumps. Your capital starts out as the center of the core sector, and any colonies you found within four systems will join that sector automatically.

Note that the option to create a sector only shows up if the selected planet is not already part of a sector. For non-core sector worlds that button disbands the sector, for core sector worlds it allows you to move your capital, and for your capital it does nothing.

  • 2
    @tatsu As expected this iteration of sectors is a steaming pile of... decomposed figs. The AI automation is a joke for sectors. You're better of doing things manually still.
    – Xander
    Commented Jun 5, 2019 at 6:17
  • 1
    @tatu I tried it last night a bit and it seems that you cannot manually add planets to sectors. As the dev diary says once you click the create sector button from a planet, it will add all planets within 4 jumps to that sector. If you have no planets nearby then it will create a sector with 1 planet...
    – Xander
    Commented Jun 5, 2019 at 6:43
  • Do new planets within that reach get added to the sector? Commented Jun 5, 2019 at 9:07
  • 1
    @Shadur: Yes. The sector encompasses all systems within 4 jumps (that don't already belong to an older sector) whether or not they have planets in them. New colonies you set up there will already be part of the sector.
    – Cadence
    Commented Jun 5, 2019 at 9:28
  • 1
    @Cadence I get and approve of the move towards a more macro focus but it should definitely be allowed to select planets from the list of planets in the "Planets & Sectors" menu and have that same button there too because this interface is so high up in the main menu order and yet it's utterly useless without it. Plus it's called "Planets & Sectors", for crying out loud! If they aren't going to add the ui element there then they should at least rename it and maybe move it down to signify it's lower usefullness.
    – tatsu
    Commented Jun 5, 2019 at 12:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .