4

I'm able to log into my Minecraft account on my phone, but I can't from my laptop. I'm using this page to log in. Is that the right one?

enter image description here

I tried to buy the Minecraft Java Edition on my phone, but, after entering all my details and pressing the purchase button, I get a message saying "You need to enter a profile name", even though I have entered a profile name, and it is available.

enter image description here

It feels like someone really doesn't want me to buy this game!

Update

I was able to log into my account with the Minecraft launcher. I clicked the "Buy the full version on the website" button, and was able to log in within Chrome. However, I can't access my profile page.

enter image description here

What the hell is going on?!

Update 2

I tried using Safari instead of Chrome and was able to access my profile. I'm still not able to buy the game though.

enter image description here

This is seriously weird.

Update 3

I tried using Firefox and got a popup when I clicked the purchase button. So far, Chrome, Safari and Firefox have given me different errors. Is the Minecraft website broken or something?

enter image description here

Update 4

I've tested 4 different browsers on 3 different networks and none of them let me buy this game. Maybe someone is trying to tell me that I shouldn't spend $35 on this.

  • 1
    Yes, that is the website. It seems like something is blocking website elements, maybe an ad blocker. I recommend using your phone as a WiFi hotspot and turning off all extensions in Chrome. BTW, this isn't really a gaming question, but it's very related and a good quality question, so I'll not vote to close. – Fabian Röling Jun 15 at 9:16
  • 1
    Then maybe it's some firewall or antivirus issue on your computer. – Fabian Röling Jun 15 at 10:53
  • 1
    Have you tried different payment method? – Zendy Jun 17 at 5:48
  • 1
    This seems like a much better question for Mojang Support. help.mojang.com – Linus Juhlin Jun 17 at 5:50
  • 1
    @Joachim I don't have any anti-virus software enabled. I know that JavaScript is definitely enabled (it's 2019!). I'm gonna try using PayPal. – Kerndog73 Jun 17 at 7:06
4
+100

This often happens when your payment method is not available.
You could try to add your CC to Paypal and try paying using Paypal.

6

Even if this question has an accepted answer, let me explain what those error messages mean.

First, I'm not that good on Javascript (the programming language that the page uses) and React (the framework being used).

Uncaught Invariant Violation: Minified React error

From StackOverflow, this indicates some formatting problem on the page source code. Nothing that you can do from your side.

Try to clear your browser cache.

Failed to load resource: the server responded with a status of 401 (Unauthorized)

The 401 HTTP code indicates that you are not authorized to see a specific page. In this case, accessing the Mojang API (https://api.mojang.com/user). If you can log in, start with that.

If you keep getting this error, clear your site cookies.

Cross-Origin Read Blocking (CORB) blocked cross-origin response with MIME type application/json. See https://www.chromestatus.com/feature/5629709824032768

SecurityError: Permission denied to get property "href" on cross-origin object

The page tried to load a JSON file from another website (Microsoft.com) and Chrome/Firefox didn't allowed it for safety reasons.

Failed to load https://api.mojang.com/user/profile/agent/minecraft/name/Kerndog73 resource: the server responded with a status of 404 (Not Found)

The page tried to check if your username is available, and it is. This should not affect the page.

Failed to load https://api.mojang.com/user/profile/agent/minecraft/name/Kerndog73 resource: the server responded with a status of 400 (Bad Request)

The page tried to check your username again but did the request incorrectly and caused the "You need to enter a profile name" message.

XML Parsing Error: prefix not bound to a namespace

The SVG image is not valid. This does not affects the page other than cosmetically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.