1

So I'm trying to make a custom superflat world on my server. The wiki says that I need to put flat as the level-type, and I need to modify the generatorName, generatorVersion, and generatorOptions. The thing is, there's no more info on this, although I think it might be important. But for now, I found this thing called generator-settings line in my server.properties that was originally blank. The wiki says that it is "The settings used to customize world generation. See Superflat and Customized for possible settings and examples." But there is no more info about it in the superflat page. So what do I put there? I've tried doing the preset but that doesn't seem to work. Am I doing something wrong here?

1

This feature is currently (since 1.13) completely broken. Whatever you put in, it's completely ignored. Here is the bug report https://bugs.mojang.com/browse/MC-134900

For now you have to create the world in Singleplayer, then copy it over to the server. Make sure to name the folder "world" (or edit the level-name property).

Update for 1.16: The previous bug was supposedly fixed, but it still doesn't work, instead the server now crashes even with a valid input, because it actively edits the file to contain invalid input for some reason. I created a new report for that: https://bugs.mojang.com/browse/MC-182421

| improve this answer | |
  • what did it do before 1.13? – Ded Turtle Jun 29 '19 at 14:39
  • The regular code, like in the in-game menu, no quotation marks or anything. Example: generator-settings=minecraft\:bedrock,2*minecraft\:dirt,minecraft\:grass_block;minecraft\:plains;village; (The backslashes are added automatically if you don't type them.) – Fabian Röling Jun 29 '19 at 18:32
  • @DedTurtle The latest snapshot has supposedly fixed this bug! I will test it later. – Fabian Röling Mar 11 at 18:19
  • Well, it was a lot later. :D I tried it now, but it still doesn't work, instead the server does even more nonsense than before: bugs.mojang.com/browse/MC-182421 – Fabian Röling May 4 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.