As the title suggests...

Euro Truck Simulator 2 required an update on Steam a short while back, which I downloaded with no issues. After launching the game, and 'climbing' into my truck to get back onto the road, I realized that my truck no longer selects gears at all. The transmission shifts into any gear I want, but then shifts back to neutral the moment the gear is selected. This is in my modded save.

I decided to create a vanilla save (no mods whatsoever) to test the transmission issue out elsewhere, of which returned the same result as my modded save. None of the trucks are willing to take gears on their own, even the in-game trucks.

Now, I normally drive in sequential manual, and I have the shift up and down buttons mapped to my mouse's hotkeys. This has worked flawlessly in the past, only after the update, this has proved to be troublesome.

I then tried to drive in simple automatic, which allows some trucks to select gears, but even then it only goes up half the range before it switches to neutral (i.e. in a 16 speed box, 8 gears can only be used)

I have no idea what to do with this issue, it is driving me crazy!

Is there a setting or a console command I can use to get my transmission to work properly? I'm getting desperate at this point!

  • Have you checked the binding to make sure they're not bound to more than one option?
    – Smock
    Commented Aug 13, 2019 at 9:09
  • I have. All of my keys are bound to one button each on my mouse. Tried re-mapping the keys as well to different buttons, but got the same result.
    – GipsyD
    Commented Aug 13, 2019 at 9:25
  • There's a thread here about difficulty with H shifter but the fact it won't shift up with simple automatic chosen does seem very odd. (Also some good info here about H shifter config)
    – Smock
    Commented Aug 13, 2019 at 10:22
  • Also check this thread which talks about unassigning drive+reverse when you map gear up + down (again it's weird that you can't auto-shift properly).
    – Smock
    Commented Aug 13, 2019 at 10:57

1 Answer 1


I have managed to solve this issue with a rather simple fix. I read somewhere that the config file with the ETS2 directory in documents sometimes "goes bad", and that it needs to be deleted. Once the file is deleted and the game is launched, the game will create a new config file with default values, and uses that from that point onwards.

I've done what is said above and now I am able to go through my various ranges of gears with ease.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .