6

I'm playing Elder Scrolls: Skyrim as a Khajiit and whenever I enter Fort DawnGuard to start the DawnGuard dlc, the NPCs present there are attacking me; Isran and that other guy. It only happens when I enter inside the Fort, the guard standing at the entrance is not getting aggroed.

I've googled the above problem and I've seen that this problem might arise if I got any crime records in Riften, but I've got a clean sheet in all the provinces.

As for the mods, I'm only using the Moonlight Tales: Essentials and yes, I can transform into a werewolf.

Is there any way to fix this issue?

I don't think it matters, but I'm wearing the Thieves' Guild armor set.

3

Because most of the time it's quite impossible to know exactly why Skyrim behaves the way it does, I assembled a few possible culprits and/or solutions from various sources:

  • You might have the cursed Ring of Hircine: if so, you need to finish that quest first [i.e. 'Ill Met by Moonlight']
    source

  • I be[a]t them up for a long while, leveled up, ran away to the top, waited for 24 hours, slept for 24 hours, entered unarmed, and they weren’t hostile
    source

  • On my third attempt to get Dawnguard working, Durak asked me to go the fort. When I got there, Durak and everyone attacked me and the quest was broken because the quest-giver would not stop attacking me long enough to give me the quest. On my machine, I was able to fix this by deactivating Dawnguard and making a clean save and starting the quest over again.
    source

  • I had this problem ...half way through my dawnguard quests they became hostile to me, so I just ran before Lydia killed any of them ... I figured the problem was I had killed some guards earlier, and even though it said my bounty was removed, it glitched the Dawnguard...so my fix is go to Riften, punch a guard, pay the 40 gold, and all is forgiven
    source

  • I fixed it by saving outside the entrance to the Vale, exiting the game, disabling Dawnguard mod, load up, immediately make a fresh save, exit, re-enable Dawnguard mod, then load once more.
    source

The solution with the most potential seems to be the following one, however, using the console:

  • I was having the same problem, Isran and Tolan attacking me as soon as I entered the fort proper. To anyone else having this problem, add Tolan to your faction:

    "Addtofaction 0005A1A4 1 adds an NPC to the player ally faction, which will make a normally hostile NPC no longer hostile towards the player."
    source

    Targeted Tolan in the console, used that command, and I am now good to go.
    source

  • 1
    Thanks for the detailed answer, @Joachim. I haven't began any quests related to the Dawnguard, so the first four solutions you listed didn't work. But the last solution completely solved the issue. Thanks again for your effort. – SlayerDiAngelo Jun 22 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.