2

When I am using dual monitors, my mouse constantly leaves the game. I have gone into Settings > Mouse and Keyboard and changed Confine Mouse Cursor to smart and to On and neither setting restricts the mouse to the game.

How can I make it so the mouse will not leave the game window?

2

In order to resolve this, your mac needs to grant elevated permissions to the Heroes of the Storm client. You can trigger your Mac to prompt for these elevated permissions by choosing the option in Settings > Mouse and Keyboard > Disable OS Keyboard Shortcuts

This will pop up System Preferences and a message saying you need to grant permissions to Heroes of the Storm.

If you're not already in Security & Privacy, select that option. enter image description here

Go to the privacy tab, unlock the settings by clicking on the lock at the bottom left and typing in your password, then put a checkmark next to Heroes. This should fix the issue where your mouse is not confined. You can now use Smart or On confinement. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.