10

I have a direct wired connection between my desktop (host) & my laptop (client) via a single router, and when steam in-home streaming connects it shows "relay" instead of "direct" in the ping section of the performance overlay stats, and the ping is SLOW, it should be 1ms but it's 50 ms.

Why is this? How can I get it to do a direct connection? I've tried:

  • restarting steam on both machines
  • resetting my internet connection
  • disabling IPv6,
  • re-seating the network cable
  • running speed tests & pings
  • disabling the firewall
  • disabling windows telemetry,
  • disabling antivirus.
  • verifying there's no VPN
  • uninstalling extraneous network hogging services (background services)
  • disabling unused network adapters (including virtual ones)

Both are Windows 10 machines on the latest version of Steam

I'm stumped

1 Answer 1

14

When Valve released Remote Play, it seems there's a bug where multiple network adapters (from VPNs, virtual machines, etc.) can cause direct connections to fallback to relays too greedily. You need to force the IP connection.

Open Steam Console ( if that link doesn't work, paste this into windows run: steam://open/console )

Run this command connect_remote <ip>:27036 where is a local IP of your host PC

You should see ping as <1ms on wireless (set router in N-only 5ghz, highest channel bandwidth) or better yet, wired.

Don't forget to enable hardware encode/decode on host/client.

3
  • 2
    This worked fantastically, thank you so much. Is there any way to save this setting so that you don't have to manually run it each time? Or should Steam remember? Nov 25, 2019 at 8:23
  • I second this request. Anyone knows of an automatic way to do this? Feb 24, 2020 at 21:13
  • 2
    Update on my comment: apparently, when you have launched this steam command once, you do not need to launch it again. However, if like me you often switch between WIFI and Ethernet, then the remote play can fail to detect other computers, and show the "Status: not connected". Launching this command again solves the issue. It's the perfect solution to make remote play work. Feb 27, 2020 at 9:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .