I have:
Passengers:[{id:falling_block,Block:command_block,Time:1,TileEntityData:{Command:"setblock ~4 ~-5 ~ command_block 1 replace {Command:"fill ~-2 ~-1 ~-2 ~4 ~3 ~2 minecraft:air"}"} (there is more code but that isn't relevant).
Anyway, when I run the command block it says there is an error:

[09:59:24] Data tag parsing failed: Expected '}' but got 'f' at: ...command_block 1 replace {Command:"f<--[HERE]

Please help :V

  • You need quotation marks. – Fabian Röling Jul 7 '19 at 10:33
  • where do i need to put them. – Squeaky Sim Sim Jul 7 '19 at 16:26
  • All the strings. Also, I just noticed that you used "Passengers". That tag doesn't even exist anymore. I recommend just taking an example "one command creation" and modifying it to your needs. – Fabian Röling Jul 7 '19 at 17:26
  • im using 1.12 also still doesn't help. – Squeaky Sim Sim Jul 7 '19 at 17:44
  • nvm i finally got it and decided to use minecarts instead, thanks for the help. – Squeaky Sim Sim Jul 7 '19 at 18:11

Yor problem is that you need to use backslashs, but I recomment to use an online website for this.
The best online website I know so far is 'mcstacker.bimbimma.net', where you can create commands like you need. You can easily generate a summon commNd there, which summons a falling block entity,
and you can set the block to 'command_block' Nd then type in the command which should be inside.

Not the answer you're looking for? Browse other questions tagged or ask your own question.