0

Whenever I type /tp @e[type=anything] @p it teleport all entities nearby and all my named entities, even though I've specified to teleport all cows, or minecart with chests, or whatever I put under type. Is there any way to fix this or use a different command?

Edit:
I was using the auto fill options and I used the command that I wrote specifically i.e. /tp @e[type=!minecraft:cow] @p , but it does it for anything I try. I am using vanilla 1.14.4.

  • Weird. /tp @e[type=cow] @s works for me, in Java 1.14.4. Could you copy paste some of the commands you tried and edit them into your question? Until then, a couple things: make sure that whatever ID you use in the type= selector is correct, and if possible, use tab to autofill. Also, maybe use @s just for clarity if you are the entity running the command? Otherwise, I'm not really sure what's wrong, but we can help you better if you include the commands you've tried. – Nik3141 Jul 27 at 23:45
  • Also, what version are you in? I remember that some syntax errors caused strange results instead of an error message in 1.12 and before. – Fabian Röling Jul 28 at 10:00
2

If you tried everything and it still doesn't work, you can also make every single entity you specify use a command to teleport to you:

execute as @e[type=anything] run tp @p

"execute as @e[type=anything]" makes it so that ALL entities that match the criteria will run "tp @p", A.K.A. to you.

Hope this helps.

0

Teleporting only works if you are an admin, so go to the pause menu and see if there is a crown next to your name. If it is anything else than a crown, you don't have permission to teleport. Also. cheats need to be on to teleport. Also the correct command is /tp [gamertag]. But make sure you don't use the straight parentheses. Also, instead of typing, open the chat menu and press the / on the left side of the chat bar that shows your unsent message. Then press teleport and the player's name. If the slash does not appear, cheats are disabled. So make sure you have admin permissions and cheats are activated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.