-1

I'm attempting to get a modded Minecraft Java Edition server up and running, but my friend joining me keeps getting the following error:

io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection timed out: no further information:

I also get the same error if I attempt to join myself not using 'localhost.'

I've forwarded the port 25565, allowed it through my firewall on both TCP and UDP, allowed all copies of Java platform SE Binary (i have many for whatever reason) through private and public, and all Minecraft executables through the firewall, but in case that wasn't enough I then turned off my firewall entirely, reinstalled Minecraft and did it all over again. My friend has the exact same mods as the server and I, the same Minecraft version as the server and I, but still gets this error. How do I fix this?

EDIT: It also does not work in vanilla.

  • 1
    I'm voting to close this question as off-topic because it's tech support for modded Minecraft. – Fabian Röling Jul 28 at 10:01
  • @FabianRöling The fact that this version of Minecraft is modded doesn't seem to matter for the situation, though. – Joachim Jul 28 at 10:21
  • @FabianRöling I just tried in vanilla, same problem. – CrimsonCuttle Jul 28 at 15:45
  • @Joachim I had already looked through that thread, and made a new page becasue none of the solutions from that thread fixed my problem. – CrimsonCuttle Jul 28 at 15:46
  • @Joachim Then edit the question with details to the way you reproduced it in Vanilla, please, then it can be reopened (or not closed at all). And also about in what ways/why the solutions on that other Q&A didn't help you and what happens instead. – Fabian Röling Jul 28 at 16:09
0

Try turning off the firewall. I had the same problem, turning off the firewall fixed it for me.

  • I've already tried that, to no avail. – CrimsonCuttle Jul 28 at 15:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.