0

I am setting up a Minecraft Server which I have done many times before successfully. The server itself is working fine but the port forwarding is not working. I have port forwarded many times before, but I recently got a new router. I set up the port forwarding the correct way. Here is a screenshot.

Port Forwarding

I have tried every possible thing. I tried many Private IP Addresses, though I am certain the one I used is correct. I disabled my firewall and it still didn't work. If there is anything else I can try please let me know. I am using a Macbook Pro.

  • 3
    FYI there's no need to censor private IP address, since it only works on your network. (It's "private" as in "only you can use it" - not "private" as in "secret") – immibis Jul 30 at 10:22
  • OK thank you ill keep that in mind for the future – Dermot McMillan Jul 30 at 17:38
  • Did you try connecting from outside the network? Many routers or ISPs block all connections to your own IP from itself. – Manchineel Aug 3 at 20:16
1

You could use https://www.yougetsignal.com/tools/open-ports/ to check if the ports are open just to rule out the possibility of it being something other than the portforward itself and not a firewall/server issue. It seems correct to me, but I am not much of a mac user. Make sure that the "Private IP Adress" is you IPv4 Adress and not your default gateway that is the only thing I can think of. Also check if there is a "save" and "load settings" button. If you want more help send the router name so we can check the manual. Also are you sure you don't have to check the box to the left of "Minecraft" as an on off switch.

edit* Okay it turns out the port checker only works if you have your server open and running. It could be so that your port actually is working without you knowing it. I would suggest just making sure you have set up your server correctly. When you connect to it you should not use your Ipv4 adress but your "public ipv4 adress" which you can get form https://whatismyipaddress.com/ . Depending on how you've setup your server it could use your real ipv4 adress to connect which you can get the easiest from opening cmd and typing in "ipconfig" and hitting enter so try both just incase. Other than that It is 1. A problem with antivirus (not that likely but it could be) 2. Your internet provider has for some reason turned off the port (very unlikely) or 3. Something with your firewall. You could try making your own exceptions in the firewall for the ports. Other than this I am not really sure

  • Hi thanks, nisse26a, I have already checked to see if the ports were open through that website and many others. The private IP address is my IPv4 address. Also, the checkbox next to Minecraft is just to delete it and doesn't do anything to activate it and there is no save button, the router is automatically updated when you open the port. The Model of my router is an Arris SBG6950AC2. I have checked the manual on Port Forwarding and I couldn't find anything that helped but any more suggestions would be appreciated. Thanks again, Dermot. – Dermot McMillan Jul 30 at 17:48
  • I made an edit to my comment – nisse26a Aug 4 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.