0

So, I am making a server and I am using skript. I am trying to make a command that brings you throughout dimensions. Here are my commands: /overworld /nether /end Here is the script:

command /overworld:
    description: go to the overworld
    aliases: earth
    usage: /overworld
    permission: skript.overworld
    trigger:
        make console execute "/gamerule sendCommandFeedback false"
        message "&6Teleporting..."
        make player execute "/execute in minecraft:overworld run tp ~ ~ ~"
        wait 2 ticks
        make console execute "/gamerule sendCommandFeedback true"

So basically whats happening is the console command is showing up on the chat: [Server: Gamerule sendCommandFeedback is set to true] And I don't want that there. I am a vanilla kind of guy so if theres an extremely easier way other than /execute in minecraft:overworld run tp ~ ~ ~ please tell me. Thank you!

  • Is that pseudocode or do you actually use a mod that allows you to write files like that? If yes, what mod? – Fabian Röling Aug 2 at 20:11
  • As I said, I'm a vanilla guy. I don't know what pseudocode is, but I use skript. Edit: I also use minehut to host my server, if that is useful info – RowdyRhino87 Aug 2 at 20:18
  • 1
    @FabianRöling It's a Bukkit plugin – MBraedley Aug 2 at 21:05
  • @RowdyRhino87 pseudocode means fake code that doesn't actually work just to give an idea of what you are trying to do – David Callanan Aug 3 at 13:02
  • Please stop deleting and un-deleting this question! gaming.stackexchange.com/questions/355696 As a reply to your last comment there: No, Education edition is a completely separate game and has nothing to do with the original Minecraft. – Fabian Röling Aug 6 at 15:59
0

I set up a Spigot server with Skript and added the script file you've provided. When the /overworld command is run it displays this:

Teleporting...
[Server: Gamerule sendCommandFeedback is now set to: true]

To remove the latter line, simply do this:

  1. Permanently set sendCommandFeedback to false. You can also not enable it in another script! As OP in Minecraft or with spigot command run:
/gamerule sendCommandFeedback false

It will not display anything, since you're turning it off.

  1. Use this script instead:
command /overworld:
    description: go to the overworld
    aliases: earth
    usage: /overworld
    permission: skript.overworld
    trigger:
        message "&6Teleporting..."
        make player execute "/execute in minecraft:overworld run tp ~ ~ ~"

Now it should only say 'Teleporting...', and that is only shown to the player running the command as per the documentation of Skript.

Obviously this method won't work if you ever need actual command feedback, but I haven't found any other workaround so far.

  • OK. Thanks anyway. If you find anything, please tell me. – RowdyRhino87 Aug 5 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.