I'm playing No Man's Sky on PC. I received a quest to scan a few fauna from a random quest giver in an outpost on this planet I'm exploring. After scanning the requested animals, I followed the quest tracker in my HUD back to the outpost. The outpost is now empty, and the quest target is just floating in the middle of the outpost -- where the quest giver was originally.

This is what it looks like:

The Empty Outpost

I tried exiting the outpost, saving, and reloading. I also tried leaving the planet entirely and doing some other quests elsewhere in the system. But no dice, the quest giver is still missing, and the quest target remains on the empty outpost.

Is it possible to finish this quest, or is my only option to dismiss it from the list of quests? (This is one of the random secondary quests that the NPCs give out, not something in the main storyline or a guild quest, if that wasn't clear.)


1 Answer 1


This answer is taken from the information left in the comments of the question. (Please don't answer in comments!)

Since there doesn't seem any additional information forthcoming, it appears that the answer is no, once the quest giver glitches like this, it is impossible to complete the quest.

User n_plum suggested:

I've run into this problem too and most other threads mention it just glitching out. Usually just worth deleting the quest, there are plenty others like it.

User Sinatr also warned that the entire system might be affected, because multiple quests might try to lead back to the same NPC. In that case, they suggest just not taking quests in this particular system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .