2

So I'm trying to make one of those "infinite hallways" things, and when I teleport the player there is a short frame of something every time. I am teleporting relative the player shouldn't be able to notice it, but every time I teleport it makes a weird blink and is noticeable. How do I fix this? I tried 1.9 and 1.12, both of which did not work. The command I am trying to use is

tp @a[x=-299,y=56,z=-559,r=1] ~ ~7 ~
  • It doesn't do that for me. In fact, I clearly remember that there was a bug report about this and it was fixed long ago. What version are you playing in? – Fabian Röling Aug 14 at 8:36
  • 1
    Like I said, I tried doing it in both 1.9 and 1.12 and nether of them work. Should I try versions? – Kiqro Aug 14 at 9:45
  • Oh, I didn't notice that. I tried 1.14.4 and it works, but 1.12 should also work. – Fabian Röling Aug 14 at 12:00
  • This bug was originally fixed a while ago (a long time ago) but then it was broken again. Now, for version 1.14 and later, it is fixed again. – kinloch Aug 14 at 19:38
0

This is something that has worked on and off for a while - it was originally fixed, then it broke again and more recently has apparently been fixed.

The bug: MC-4686 was fixed in minecraft version 18w43a which is the first snapshot for Minecraft 1.14

Under the list of fixes for that version: MC-4686 – Client movement when teleported

So as long as you use Minecraft Java Edition 1.14 or later you should be able to use seamless teleportation without issue.

However, with later versions of minecraft you should familiarise yourself with the new command formats before trying the same old commands - the process of teleportation others using relative coordinates is slightly different now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.