2

I was cruising along in my trusty boat when I tried to get out of it in the middle of the ocean.

Now I am "standing" on top of the water without sinking. I can walk, but it's jittery and moving 3 blocks takes about a minute.

The boat has completely vanished and I am not on a server.

How do I get out of this situation without losing my diamond armor?

  • It shouldn't jitter. Have you tried to close and reopen the world? – Fabian Röling Aug 14 at 17:21
  • I've been having a similar issue with boats. I've noticed that the boat seems to glitch and cause the jitters. Have you tried jumping straight up and then trying to move in the air? – Steve-o169 Aug 14 at 17:24
  • I encountered a bug which seems very similar. But that happened when I exited a boat at a shore. It was gone when I entered and left the boat a second time. – Philipp Aug 14 at 17:25
  • @Philipp Sadly my boat vanished. I've added that to the question. – Parrotmaster Aug 14 at 17:37
  • Sounds like a combination of glitches I've seen lately... Exiting a boat causes the jitters you're seeing, but I've also had my horse disappear after dismounting. Fortunately, I was able to leave the area and come back to find my horse had reappeared. Did you close and reopen as Fabian suggested? – Steve-o169 Aug 14 at 17:54
2

Sounds like you have broken something somewhere.

The jittery movement sounds odd - sometimes it happens when you are connected to a server and you have removed a block beneath your feet but the server doesn't think you have (this can be due to lag).

However you being in the middle of an ocean makes that unlikely.

Possibly the standing on the water could be the game thinking you are still inside the boat and when trying to move it snaps you back to the boat location, this would explain the jitter and slow movement.

Whatever the exact cause of the issue however, it should be fixable by restarting the game - just be prepared to swim the moment you reconnect in case you start underwater.

If for some reason after restarting it is still broken then you can try re-entering the boat/leaving it a few times, trying to jump around/move away from the area you are stuck in.

If all else fails then you might have to resort to using commands, the teleport command might work if you teleport yourself using relative coordinates: /teleport ~4 ~1 ~0 Will teleport yourself four blocks along and one block up for example, and might move you outside the area that seems to be causing issues.

  • Sadly nothing worked. I didn't install any mods so I'm not sure what could've broken. – Parrotmaster Aug 15 at 7:14
  • @kinloch You said "However you being in the middle of an ocean makes that unlikely." but I believe you forgot about the boat. The boat is most likely what is interfering. This scenario has happened to me with boats on a server, but never in a single player world. – Ryan Weaver Aug 15 at 19:28
  • @RyanWeaver I did address the boat later on, - I meant breaking a block was unlikely to have caused it. – kinloch Aug 16 at 19:01
0

Based on comments and the other answer, I think the best remaining option for you to keep your gear is to use commands to remove yourself from the situation. First, you can set the keepInventory game rule to true so you will keep your gear.

/gamerule keepInventory true

Next, just kill yourself with /kill [yourGamerTagHere]. Finally, you can set the keepInventory rule to false and continue as normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.