I'm using a Minecraft give command generator since I can't format the commands myself. What I'm trying to do is:

/give @p diamond_sword{Damage:1000} 1


/give @p minecraft:diamond_sword{Enchantments:[{id:sharpness,lvl:2000}]}

But every time I try that command I get the error: Unknown item name

I have no idea what to do with this issue or where to search about it.

I'm trying all these on my Minecraft Bukkit Server version 1.14.4.

  • 2
    About your first command: You can't just invent any syntax you like and expect the game to guess what you mean. You have to use the exact right syntax, which you can look up in the wiki. About your second command: That works for me. Not sure if this is a Bukkit issue, I've heard that some of these mod loaders break some commands. In that case it's a bug in Bukkit. I'll add the corresponding tag, maybe a Bukkit expert knows more. And in general: Please don't delete and re-ask questions, you should instead always edit your previous question (if it's still the same issue of course). Aug 29, 2019 at 23:47
  • Thanks, still no idea what to do :(, wanted to ask on the minecraft subreddit but its too complicated to find the "sumbit" button...
    – alex201004
    Aug 30, 2019 at 18:05
  • What you do is simply using your second command, it works. If it doesn't work in Bukkit, that's a Bukkit bug (or maybe you typed it wrong). In that case you have three options: 1. Switch to Vanilla, if you can. 2. Wait for Bukkit to fix the bug. It would need to be reported first, but only if you really know the exact issue. 3. Somehow work around it with other commands. I can't help you with that, because I know almost nothing about Bukkit. Aug 31, 2019 at 12:57

1 Answer 1


This is most likely a plugin command conflict problem; this happens when two commands register themselves as "/give". My suspicion is that you have "Essentials" or "EssentialsX" installed on your server as well. The Essentials "/give" command does not accept NBT data; however, the minecraft "/give" command does. By default, Essentials registers itself as the main command; to override this and tell it you don't like its decision, change your commands to:

/minecraft:give @p diamond_sword{Damage:1000} 1


/minecraft:give @p minecraft:diamond_sword{Enchantments:[{id:sharpness,lvl:2000}]}

This is a really annoying issue I deal with all of the time on servers. Bukkit/Spigot is supposed to allow you to set the default back to minecraft, but for some reason that option is broken right now so you'll have to use the namespace for the vanilla command.

Not the answer you're looking for? Browse other questions tagged .