5

I got CnC Generals (first decade) running on Windows XP running in Virtual Box. The only thing that is quite annoying is a red, green, or blue transparent layer that gets active when some Chinese, gba or usa troop is anywhere on the visible part of screen. Is that something that is caused by a modification of tfd-103-rev4 ? Can it be disabled by configuration by some magic setting in options.ini or gamedata.ini?

If there is no troop on the current selected part of map the annoying layer disappears.

Used configuration:

  • Windows XP SP3
  • Virtual Box with 3D acceleration activated
  • tfd-103-rev4
  • Played around with gentool (without any success)

enter image description here

The same behavior appears with Zero Hour.

1

The annoying color layer went away after setting "BuildingOcclusion" in options.ini to "no". That is the config key used by the graphic setting menu for the checkbox "Behind Buildings".

That options.ini is a confing that works flawless with a XP SP3 in Virtual Box:

AntiAliasing = 5
BuildingOcclusion = no
CampaignDifficulty = 0
DrawScrollAnchor = 
DynamicLOD = no
ExtraAnimations = yes
GameSpyIPAddress = 127.0.0.1
Gamma = 50
IPAddress = 127.0.0.1
IdealStaticGameLOD = High
LanguageFilter = true
MaxParticleCount = 3000
MoveScrollAnchor = 
MusicVolume = 55
Resolution = 1280 720
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 50
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = no
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 70
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.