1

I got myself a 4K monitor and at its native resolution the Borderlands games give me low FPS:

In all 3 games at 3840x2160 resolution and all max graphics settings I get around 30-45 FPS. Just lowering the resolution to 2560x1440 gives me around 55 FPS, and going down to 1920x1080 gives >60 FPS.

Turning down all the graphics setting to low/off still gives me below 60 FPS on 3840x2160 resolution in all 3 games. Even without the HD texture packs.

Process Explorer is saying that the GPU is basically idle at 5-10% usage, while the CPU is working at around 20% total (6-core Intel i5-8400, for which 16% is 100% of a single core utilization, making it around 1.5 full core utilization). It seems like both games are bottlenecked by single-core CPU performance. What can I do to get better FPS?

2

You can disable the cel-shading post-processing effect if you don't mind losing that signature thick black outline on all 3D models. This improves framerate dramatically. For me, it jumped up to 80-120 in all 3 of these games.

There is already a Q&A about doing this but the asker specifically wanted to get rid of this effect not knowing it can actually boost FPS significantly, and that it works in all 3 games. Check it out here. The answer there also shows how it looks before and after.

Here's how to do it in all 3 games (assuming you're playing on PC via Steam):

Borderlands GOTY Enhanced

  • Go to: %userprofile%\Documents\My Games\Borderlands Game of the Year\WillowGame\Config\
    • (you can copy-paste this into your Windows Explorer window address bar)
  • Find and make a backup copy of WillowEngine.ini. If you don't see it there, launch the game at least once after installing, it should appear.
  • Find this text in it (mine was at line number 95):
    • DefaultPostProcessName=WillowEngineMaterials.WillowScenePostProcess
  • Replace the value at the end with whatever:
    • DefaultPostProcessName=WillowEngineMaterials.WHATEVER

In my case it jumped from ~45 to ~90 FPS.

Borderlands 2 and Borderlands 2 VR

  • Go to %userprofile%\Documents\My Games\Borderlands 2\WillowGame\Config\
  • Find and make a backup copy of WillowEngine.ini.
  • Find this text (mine was at line number 133):
    • DefaultPostProcessName=WillowEngineMaterials.WillowScenePostProcess
  • Replace with:
    • DefaultPostProcessName=WillowEngineMaterials.WHATEVER

For me the increase was from 30-45 to 75-100 FPS.

In VR with Valve Index the increase was about 40% extra FPS across different resolution percentage settings.

Borderlands: The Pre-Sequel

  • Go to %userprofile%\Documents\My Games\Borderlands The Pre-Sequel\WillowGame\Config\
  • Find and make a backup copy of WillowEngine.ini.
  • Find this text (mine was at line number 133 - wow, same as BL2!):
    • DefaultPostProcessName=WillowEngineMaterials.WillowScenePostProcess
  • Replace with:
    • DefaultPostProcessName=WillowEngineMaterials.WHATEVER

For me it went up from 35-45 to 80-90 FPS.


I haven't had the chance to play the new Borderlands 3 but I assume they're reusing a lot of the same engine inner workings and configs as the 2 and Pre-Sequel, so in theory, it should also work for 3. I'll update this in about 5 months when it releases on Steam.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.