3

I have CentOS 7.7 installed on my system. I've downloaded Minecraft.tar.gz from the official download site and when I try to run its minecraft-launcher binary I get the following errors:

./minecraft-launcher: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./minecraft-launcher)
./minecraft-launcher: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./minecraft-launcher)
./minecraft-launcher: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./minecraft-launcher)

Looking at my libstdc++.so.6 I see that it only supports up to GLIBCXX_3.4.19, even though my system is up to date.

Ignoring the questionable logic of requiring a platform-specific front end to run a platform-independent game, does anyone have any ideas of how I can get this to work?

I've looked into trying to install a newer version of libstdc++ on my system but most of what I read warned me against it as the entire system is closely tied to the versions of the standard libs.

The easiest solution would be to find an older version of the launcher but my searches have come up empty.

I could probably run the java client directly but again I've been unable to find a place to download it from.

The Minecraft site does provide a download for the java server, is there a way to use that as a client?

1
  • 1
    I recently had a similar problem that was (partially) solved by compiling and installing a newer version of a library in its own folder, then running the program with that specific version, which does not impact anything else on the system (or even the regular usage of that program). See the comments here: unix.stackexchange.com/questions/544193/… I don't know how one would adjust those commands to your needs, but maybe that's a starting point. Here is a similar case: stackoverflow.com/a/52617527/6743127 Oct 4, 2019 at 22:10

2 Answers 2

1

Here is a link to the old launcher: http://www.filedropper.com/minecraft_1

This will allow you to play certain versions like everything before 1.14.2 and 19w35a snapshot (confirmed by me). Download it and place in your desktop.

Run using the following commands in terminal:

cd Desktop

then

java -jar Minecraft.jar

Enjoy (:

1
  • This is a dmg file for macos (I don't know how that happened). This other version is official and works on Linux: launcher.mojang.com/v1/objects/…. However, there is no MS auth support, but it does mean there is an opportunity for me to start yet another project.
    – MrParrot
    Oct 10, 2021 at 8:21
2

First download Minecraft.tar.gz from the official download site.

Also install anaconda python (or miniconda I suppose) from https://www.anaconda.com/products/individual

This gets you the libraries you need.

Then run:

LD_LIBRARY_PATH=/opt/anaconda/anaconda3/lib ./minecraft-launcher

(Adjust these paths to match wherever you installed anaconda and the launcher)

1
  • This worked beautifully for me. Thank you!
    – Rich C
    Dec 19, 2021 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .