0

I just reinstalled Half-Life 2 on this system, movement in the game is sluggish compared to what it was the last time I played it.

Here are the symptoms that i've noticed:

  • The sprint doesn't make me go any faster, but it still drains my AUX-power.
  • Moving through vents and other cramped areas is almost not possible
    as Gordon is moving about an inch per second.
  • The airboat doesn't accelerate properly in water or on land. whenever it's on land it's moving as slow as I did in the cramped areas.
    However, it accelerates properly when I reverse.

Solutions as mentioned in the post below have all been tried out.
Gordon Freeman runs way too slowly!

Here's a list of things I've tried:

  • Entering the value "sv_alternateticks 0" into the console.
  • Manually unbound the sprint key and rebound it using the console,
    • Tried binding it to other keys and it made no difference.
  • Pressed the "Use Defaults"-button in the key bindings menu.
  • Changed the steam overlay key binding in a way that shouldn't interfere with any button used in game.
  • Alt tabbing.
  • Tried toggling V-Sync.
    • Tried limiting FPS to 90 and 60 using the "fps_max" console command.
  • Checked if VR settings was still active, which the menues indicated that they were not.

I play this on a Windows 10 Pro 64-bit system, that has tried playing this game in VR before.

How would I go about diagnosing and fixing these issues?

  • Do you have a controller plugged in? – Smock Oct 14 at 9:59
  • @Smock Hi, no controller plugged in, and no VR headset plugged in. The issue was resolved by removing the autoexec file followed by rebinding my keys. – Thomas Fonn Oct 14 at 10:02
  • Ah, I just see that it's your own answer below! Great to hear you solved it. – Smock Oct 14 at 10:05
1

In the folder the following folder:

Steam\steamapps\common\Half-Life 2\hl2\cfg

there is a file called autoexec.cfg that will run as soon as the game starts, it contained the following information on my system:

vr_translation_limit 1000;
vr_hud_max_fov 50;
crosshair 0.0;
fps_max 300;
bind "v" "vr_reset_home_pos;"
bind "JOY10" "vr_reset_home_pos;"
cl_forwardspeed 75;
cl_sidespeed 50;
cl_backspeed 50;
cl_upspeed 25;
alias "+fast" "cl_forwardspeed 200;"
alias "-fast" "cl_forwardspeed 100;"
bind "shift" +fast
alias "+duckfast" "+duck; cl_forwardspeed 200;"
alias "-duckfast" "-duck; cl_forwardspeed 100;"
bind "ctrl" "+duckfast;"
alias "+sprintfast" "+speed; cl_forwardspeed 450;"
alias "-sprintfast" "-speed; cl_forwardspeed 100;"
bind "alt" "+sprintfast;"

most of which explains why movement is altered.

Change the name of the file to BACKUPautoexec.cfg to ensure that you can still find it again if you need it. This also ensures that it won't run automatically every time you run the game.

Start the game again and rebind your keys to whatever you like and it should work just fine.

  • It's weird your autoexec.cfg contained those edits to begin with, and, searching for the contents, you probably picked them up along the way from this reddit thread. – Joachim Oct 12 at 15:33
  • @Joachim you are right! While searching for the cause I got reminded that I did try to play it in VR a few years back and it didn't work very well, so I uninstalled it (which is why I tried to eliminate that as a cause). Maybe the autoexec didn't get properly removed during the uninstallation or got stored in the steam cloud somehow? – Thomas Fonn Oct 12 at 16:48
  • If you use Steam, then no, it probably didn't, as it was edited by you. All edited files usually are left untouched when you let Steam uninstall something. – Joachim Oct 12 at 19:45
  • Although files in the manifest/payload/package will quite often be overwritten on reinstall/patch/verify. autoexec.cfg isn't a default payload file though - which is why it will stay there in it's edited form so long as you don't remove the repository folder. – Smock Oct 14 at 10:24
  • @Smock Thanks for clarifying :) – Thomas Fonn Oct 14 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.