9

I play Minecraft 1.14.4 vanilla on a server I host for a few friends and family. Server version is 1.14.4 as I confirmed from the server log:

Starting minecraft server version 1.14.4

I am in the process of building an ice farm that makes use of water streams that transport the player along a horizontal route.

As water push strength got reduced in 1.13, each segment of the water stream is 5 blocks long and has ice below it. However, the force is still not strong enough to keep the player moving.

I built the same setup in my local creative test world. Strangely, in this world the water streams work fine. I disabled all datapacks that were in use to ensure that they do not create the issue.

I verified that the issue is related to the world itself, not to the multiplayer aspect, by downloading the world save and testing locally. The issue persists. I also tried switching to creative which does not make a difference. Further, I tried multiple locations within the world - all to no avail. There seems to be some issue with the world save itself - I am at a loss.

The world itself was created in version 1.13.2 and later, with the release of 1.14.4 converted to the recent format.

This is my test setup that works fine: Waterstream with ice As you can see, I tried with different types of ice below the water. They all work as expected. I also tried them as a single block width channel which worked fine.

This is the setup on the server which does not work: Water stream with ice For debugging purposes I also tried reducing the length of the waterstream to two blocks - to no avail. Travelling speed is as slow the entire time as it would usually be on the last few blocks. Am I missing something here?

After more debugging, the issue seems to berelated to the level.dat file. This is how I tested it:

  1. Create a new world
  2. Replace the level.dat
  3. build a water stream

The level.dat I used can be found here.

Note: To clarify: The player shall be moved by itself, there are no boats inplay here - see the video above for an example.

11
  • 3
    Hi there, welcome to Arqade! Thank you for your well thought-out, detailed question. Though I personally don't know the answer, hopefully someone in the community can help.
    – Gigazelle
    Commented Nov 1, 2019 at 18:18
  • 1
    @Gigazelle Thanks for the warm welcome. I know how important it is to think a question through, I am happy you noticed. I hope it fits the scope on arcade.
    – T3 H40
    Commented Nov 1, 2019 at 18:23
  • You're using a 3 blocks wide water stream in the test world and a 1 wide one on the server? Then that's probably your problem. Boats are wider than 1 block. Also, sometimes lag can do weird stuff to boats, minecarts, horses etc., but if you locally host the server, there shouldn't be much difference. Commented Nov 1, 2019 at 21:20
  • @FabianRöling There are no boats at play here, the player is pushed by itself. I clarified this point in the question. Also, channel width has no effect on the speed, I just tested that to verify
    – T3 H40
    Commented Nov 1, 2019 at 23:10
  • 1
    @FabianRöling During some debugging today I found that the issue seems to relate to my level.dat. I created a new world where the water stream worked fine, then replaced the level.dat file with the one of my server and the stream was broken. I am looking a little deeper into it and see wether I can find something. NBTExplorer did not yield much - my current trace: The Version property of the level file still says "1.13.2", maybe there was an issue when switching the server versions back then.
    – T3 H40
    Commented Nov 2, 2019 at 12:02

1 Answer 1

3

After more debugging, the issue seems to berelated to the level.dat file. This is how tested it:

  1. Create a new world
  2. Replace the level.dat
  3. build a water stream

Doing the above copies your armor. Take off your Depth Strider III boots. They are the issue.

I copied the .dat file and on reload my character was in a different spot, had differnet equipment on, and the inventory was differnet. So I looked at the boots, saw the enchantment, and took them off. Then my water stream test worked just fine.

2
  • 2
    I am facepalming so hard right now! If that really is the reason, I can't believe I did not check that :) thank you for the hint. I will check it out as soon as I can. Until then have a good start into 2020
    – T3 H40
    Commented Dec 31, 2019 at 18:31
  • 1
    Can confirm. I mined 250k ice in an ice farm without water stream. Others did as well. This oversight wasted hours! Thank! you!
    – T3 H40
    Commented Jan 6, 2020 at 9:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .