0

I recently installed the two plugins ChestCommands and LordPermissions. But I find that I'm either using the permissions incorrectly or something is going wrong.

I'm trying to make non-op's able to use my ChestCommand 'mainmenu' menu, so I tried this in LordPermission's globalgroups.yml file, under the default un-opped group:

- chestcommands.open.mainmenu.yml (I also tried this with inverted commas - ' - round the sides but this didn't work either).

In the log and the console, it doesn't come up with any errors, but in game. When I try with my un-opped alt account which is in the group which should have access to - chestcommands.open.mainmenu.yml, it says in chat:

You don have permission chestcommands.open.mainmenu.yml to use this menu

The two links to the Plugin Details are listed below, (I am using 1.8.8 Spigot/Bukkit by the way): https://dev.bukkit.org/projects/chest-commands https://www.spigotmc.org/resources/lordpermissions-1-7-1-11.10930/

  • I'm not sure if this falls under technical support for modded Minecraft. The problem seems to lie with commands being used improperly, which is still gameplay support. On the other hand, this might not be the best platform to ask for it (which naturally doesn't disqualify a question). – Joachim Nov 21 '19 at 12:14
  • I think this is a question that involves wording to be open or closed. Phrased as 'my modded commands are not working' certainly falls under technical support for modded Minecraft. If it was reworded in such a way that discusses the mod's capabilities with a how-to focus, it could more easily reside in the realm of being on-topic. – Gigazelle Nov 21 '19 at 20:08
1

I think I found the answer to it myself. All you have to do is have only chestcommands.command.open and not include any other permission nodes

Not the answer you're looking for? Browse other questions tagged or ask your own question.