0

I've been trying to figure out how to change a player's gamemode from adventure to survival when walking out a certain radius. The map size I'm using is 2956x2956 & I wanna be sure to cover all of it. I tried using /gamemode creative @a [r=10] with a repeat block just to test out what'll happen. But no matter how far I am from the block it keeps setting my gamemode to creative. Can someone show me how to properly write what I'm trying to do for minecraft 1.12.2? Screenshots would be much appreciated. (also how can I stop the commands from blowing up my chat lol?)

0

If your command is actually as you wrote, your mistake is that there is no space between "@a" and "[r=10]". Here it is:

/gamemode creative @a[r=10]

And well, if you need it for 2956x2956 radius, simply change [r=10] to [r=2956] (Maybe 2956 won't be enough as the raidus is circular and not a square form. Test it out and see how big does it need to be).

Also, to disable the command feeback in chat, simply type in you chat:

/gamerule commandBlockOutput false

This will disable any and every feedback that otherwise the command would send to your chat.

  • Ok, you were right about the spacing lol. But how do I connect another command block to switch back to survival when outside the radius. And is there no way for me to change the circular radius to a more cubic shape? – SolarSaga Nov 21 at 17:45
  • No, you cannot change it to a cubic chape. To set the out of bounds radius to survivale, do /gamemode survival @a[rm=2956] , in which rm stands for Minimun radius. So anyone beyond the radius of 2956 will have their gamemode changed. You can also set up a maximum with [rm=x,r=y] so the game doesn't have to check trough the whole world, but that means if they teleport outside that range, they will not have their gamemode changed. – Bruno Rodrigues Nov 21 at 20:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.