As I understand this is a somewhat common issue; but common fixes aren't helping. Minecraft is currently not allowing me to connect to any servers. It does not appear to be a firewall issue as disabling the firewall does not change results, I added a rule to the firewall also, but could have easily messed that up. I believe the issue is due to a VPN which enables a firewall when it protects my network. I have tried to disable the VPN and even uninstalled it to no benefit. I have tried restarting my internet and connecting to a different internet. Nothing helps. I am incredibly not tech savvy pls help.

Edit: tried changing versions, which I assume would avoid the issue listed in this very similar post: How to solve the "io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information" error on Minecraft?, that is to taken with a grain of salt however this is so very not my forte.

Edit: Minecraft has been uninstalled and reinstalled to no avail.

  • 1
    The question you linked doesnt mention changing versions that I see, it says that it is a firewall issue. Are you running AVG, or something similar? If so, try momentarily disabling it to see if you can connect
    – Dragonrage
    Dec 3, 2019 at 22:34
  • because it mentioned allowing version-specific jar I thought maybe changing versions would help. Funnily enough virus protection has been off for god knows how long so I doubt it has anything to do with it.
    – muckfeat
    Dec 3, 2019 at 22:41
  • 1
    Are you running on windows? if so windows defender can also block it if running
    – Dragonrage
    Dec 3, 2019 at 22:42
  • I am running on windows, but I have disabled defender to no benefit.
    – muckfeat
    Dec 3, 2019 at 22:48

1 Answer 1


Upon attempting to re-add servers they work; i do not know if anything that i tried helped. but i recommend re entering a server as a formality if nothing else.

Not the answer you're looking for? Browse other questions tagged .