20

When I Alt+Tab or use a Windows key to get out of a game (in this case World of Warcraft) and use a Windows feature or other program like Chrome, when I return to the game, I experience a 1-2 seconds black display.

This also happens when I use keyboard shortcuts to change volume and the Windows volume bar appear in game. I checked for graphics cards updates and also disabled Focus Assist in Windows, but the problem still persists.

I plugged my monitor to my motherboard and it looked fine anyway, but with changed settings in game.
I have 2x GTX 1070 Ti, and my monitor is LG 29" Wide Screen, and I run everything on Windows 10.

Do you have any idea or anyone have faced this problem ?

  • Comments are not for extended discussion; this conversation has been moved to chat. – Robotnik Dec 11 '19 at 23:40
67

This is normal for exclusive fullscreen games. It has to reinitialize DirectX and have it take over the display again. Try using Borderless Windowed instead of Fullscreen if the game supports it if you don't want to have this issue.

As for the volume overlay also causing the issue, John said below that either Windows or some program is trying to display something that is not the exclusive full-screen game.

  • 41
    "I'm not sure why this would happen when changing the volume however" Probably because Windows 10 draws an overlay to show the current volume whenever it's changed, so it has to take exclusive mode from the game. Interestingly, the same behavior also happens when playing a game that doesn't support HDR on an HDR screen with HDR turned on in Windows. In this case, the black screen is because the display has to switch between SDR and HDR mode. – Nolonar Dec 8 '19 at 23:20
  • 4
    @Nolonar The Windows overlay doesn't do this; but there might be a special audio driver that does this wrong (as has often been the case in the past). Or the GPU drivers might be to blame, of course. – Luaan Dec 9 '19 at 8:59
  • 3
    The OP specifically says "change volume and windows volume bar appear in game" so either Windows or some program is trying to display something that is not the exclusive full-screen game. Your answer is correct and you might want to add that portion to it as well. – John Hamilton Dec 9 '19 at 9:26
  • 6
    This cannot be OP's issue. World of Warcraft does not have an exclusive fullscreen mode anymore and borderless windowed is default. – Belle Dec 9 '19 at 15:13
  • 3
    @Belle-Sophie Color me corrected. Thank you for the source. BlueRaja's answer has some insight into this but it still shouldn't be the source of the problem. Maybe something to do with Nvidia profiles? Like it is forcing the game to be exclusive fullscreen but the game is actually acting like borderless towards the OS, so the OS can't tell the difference and just interrupts the game with overlays. (Seems like a stranger problem than I first thought.) – John Hamilton Dec 10 '19 at 9:02
22

The other answer is incorrect. This used to be normal for exclusive fullscreen games. However, beginning with Windows 10 v1803 (March 2018), Microsoft introduced a feature called "Fullscreen Optimizations" that forces all games to use Borderless Windowed mode, even when the game requests exclusive fullscreen.

This feature is always on by default, but a number of things can cause it to stop working. These include:

  • If you disabled Fullscreen Optimization for the game or disabled it system-wide, the slow alt+tab behavior will return. Many gamers do this intentionally because exclusive fullscreen has better performance.
  • Focus Assist previously broke it. I believe this has been fixed in the latest version of Windows.
  • Several version of NVidia drivers have been known to break it, so make sure to update your drivers.
  • Certain version of Realtek drivers have been known to break it. I don't think those were ever fixed, so your only option may be to uninstall those and use the default Windows drivers.
  • From this similar question, make sure GPU scaling is disabled and your refresh rate is set correctly in your GPU control panel.
  • 1
    We may be talking about WoW classic here? And maybe it needs some kind of 'Old Windows emulator' while it's running, that it has to desactivate when it's not focused, and reactivate when it is? – Fredy31 Dec 9 '19 at 20:02
  • 2
    @Fredy31 That is unlikely. WoW classic uses the same engine as the current expansion and runs on DirectX 11. It is written with Windows 10 in mind. – Belle Dec 10 '19 at 8:48
  • Source on "exclusive fullscreen has better performance"? Can you produce any benchmarks on modern machines/games showing any significant difference? (Assuming optimizations off) – Tyler Shellberg Dec 10 '19 at 18:11
  • @TylerShellberg: Prior to "Fullscreen Optimizations", the difference was significant and easily measurable, but now I'm not sure. Anecdotally, I seem to get fewer FPS hitches with Fullscreen Optimization disabled, but disabling it also frequently causes other graphical glitches so I usually leave it enabled. – BlueRaja - Danny Pflughoeft Dec 10 '19 at 19:31
  • 1
    Add "launch manager" to the list as well. It's a built in background program for displaying audio change overlays on gateway computers (?) and I've had it cause a few anomalies on my windows 7 pc in the past. Note: My LM install got dismantled at one point and quit working due to accidentally running an uninstaller for a program I never installed via the installer. I think it was just a PATH variable mishap removing it from my startup list, but it is still worth mentioning in your list if anyone else can confirm. – user64742 Dec 11 '19 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.