11

While playing Jedi Academy with the Moviebattles II mod on Steam I suddenly had an issue where if I tried to walk straight forward my character would freeze. I then found that I had a similar issue in the base game: in single player walking straight forward would cause my character to slow down and play a weird bouncing animation, however, multiplayer worked fine. I removed the mod and completely deleted every single file relevant to the game and then re-installed and it still won't work, a process I've repeated several times. I tried installing Jedi Outcast as well and I can't walk straight forward there either. My OS is Windows 8.1. I have tried using openJK but that didn't fix it.

When I use Moviebattles II through the MBII client (which uses openJK) the issue seems to go away there, however, it still persists in single player, and prevents proper Steam Integration.

I've now found that even when using the MBII client I have similar issues while holding the crouch button. My character starts 'bouncing' up and down but isn't actually moving.

Does anyone have any idea how to fix this?


Update: I tried using the game on my Windows 10 laptop and it works fine on there. I only get the glitch on my Windows 8.1 PC

Update: I have still found that the crouching issue persists in the MBII client version of MBII. I also found that when moving forward and to the side (by holding W + S or A) my character will slow down but not bounce up and down.

Also when holding onto the tab key to show the scoreboard/player list it would constantly go away and come back, a sort of flickering. Also when holding the use key for something that requires it to be held for a few seconds (like unlocking a door) it would constantly reset my progress so it was impossible to accomplish.

I decided to update the graphics drivers for my GTX 1050Ti since I hadn't done that for over a year, I did this and selected to do a fresh install. This seems to have slowed down the issue but not fixed it. By this, I mean that my character still slows down in those movements and the ones that made them bounce up in down still make them bounce but at a slower rate. The flickering of the scoreboard and the use key still have issues but they reset at a slower rate.

I wonder if it's some issue where I have some sort of turbo key activated somehow.

Edit:

As I have continued to play this game I have also had issues where the game would freeze for a second or so, mostly when I'd just joined a match. Then while I was playing duels my game froze and I was immediately killed because of it, my audio cut out that exact moment, and when I tried to minimize the game using MBII's keybind to do so it just turned black and was frozen, so I had to restart my PC. After this, I entered the game again and at the loading screen for a match, my audio went away again, I closed the game and when I tested my audio using Windows' built-in way to do so it said that it failed to play. Windows' recommended I switch my headset to connect to a different USB port but it didn't work so I reset my computer again. After I did so it said it was installing the headphones, and ever since then, every issue I had with the game has magically gone away. The thing is just a couple minutes before I tried updating the audio drivers and it did nothing.

Well, I'm beyond glad that it's fixed but I still don't know why it happened nor why it went away, so if anyone comes to any understanding they can post an answer.

  • I'd recommend starting to edit the question with updates and such to bump it back up on the home page. Don't know why it's getting so few views. – Robbie Dec 28 '19 at 6:07
  • Is there any way you can test this on a different device? – Ellesedil Dec 30 '19 at 17:44
  • @Ellesedil it works fine on my windows 10 laptop, but I don't see why it wouldn't. – DJ Spicy Deluxe Dec 31 '19 at 0:35
  • Did you try a Steam repair installation? Uninstall is not the same thing, and Steam tends to leave user-added files intact to preserve mods. Doing a repair will explicitly tell Steam to make sure every file is correct. You may have left over files from the mod that is affecting the game. – Nelson Jan 2 at 2:09
  • @Nelson Well I have manually deleted every last file, so I don't think that would fix it. Did you mean verifying file integrity or something else? – DJ Spicy Deluxe Jan 2 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.