2

My controller works fine on the PS4 main screen. Can access everything displayed and all the buttons work fine. But, when I go into an app or game, I get no response from the controller. Have tried every suggestion I could find concerning the controller not working - reset controller, restarted console, unplugged console, deselected from Bluetooth and reselected, etc...

3
  • Not going to as an answer, since it could be a number of things, but sounds like you might have a sticky or malfunctioning button or trigger, which is overriding the input given when you try to navigate through the game's menu. I experienced something like this a while back Jan 23 '20 at 20:41
  • Thanks for the reply. It's like the console is preventing me from playing games or apps. I thought it might me something with parental controls/restrictions, but didn't find anything. Like I said. I can navigate the main page and access PS4 related functions, but anything else does not respond to my controller. I did notice that when I was signing in, the L2 trigger did not work, but don't know how that could effect my problem... Jan 25 '20 at 0:14
  • Related
    – Ben
    May 15 '20 at 3:24
1

There could be any number of things that could be contributing to this issue.

As you mentioned, you have tried the default options, of resyncing, resetting, etc. Some other options might be:

1. (as provided by Wondercricket) Clean your Controller:

sounds like you might have a sticky or malfunctioning button or trigger, which is overriding the input given when you try to navigate through the game's menu.

I personally have had a similar issue that resulted in the controller exhibiting odd issues, and after sending it back to my local game store to get it cleaned (for a small fee) the issue no longer occurred.

2. Keep the Controller connected to the PS4, to see if that has any effect.

If this solved the issue, it's likely there is some kind of communication error occurring over the wireless connection. Again, this could be repaired by your local EB/GameStop.

3. Try a different Controller

Sadly, this problem might not actually be anything to do with the controller itself - it may be your console. Again, I have experienced an issue recently where the PS4 was acting very strangely - it was not communicating with the controller properly, and the game I was playing would not load. After some further investigation, the same issues were occurring with a different controller, and different games, and even to the point where it would "freeze" while attempting to trim videos captured using the "share" button.

1

I had a little piece of plastic stuck in my R2 trigger so either you have something stuck in one of your buttons or triggers or i don’t know

1
  • Are little pieces of plastic compatible with the PS4? All the buttons work fine on the PS4 main screen, according to the OP.
    – Joachim
    Oct 25 '20 at 8:48
1

Sorry for answering an old question, but I’ve just had the exact same issue. Namely that I have control in the menu but not within an app.

Things that didn’t work:

  • Restarting/shutting down/unplugging the system
  • A system update
  • Looking for app updates

The only thing that worked for me was entering the app then shutting off the controller, then activating the controller.

  • Hold the PS button
  • up to Device/volume
  • down to Disconnect Device
  • Select Dual Shock 4
  • Wait until its off and then press the PS button to start the controller.

Note that this has to be a software related issue as its consistently happening in a specific on-screen context. It can’t be a physical issue with the pad, as asserted in other answers.

Note: this is a partial fix as it still happens every time I open an app, this just lets me recover from it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.