When I start my PC (Win10), Steam also runs in the background. You can clearly see it and end processes from the task manager, but it still has enough time to log in before you can do that, using your credentials and letting Steam know you just turned your computer on, even if it's for something else altogether and you never even looked at the Steam icon, they're watching you, sharing your data.

I see lots of posts about preventing it from signing in or starting/launching on boot, etc, but this only keeps the app itself from opening/launching for you to interact with, it does not stop background processes. I first noticed when unplugged from the internet and started my PC, a steam prompt started kicking errors like not being able to reach your friends, all without actually launching Steam.

How do I stop Steam from automatically running in the background when I boot up?

  • 1
    Are you talking about the steam client (browser) itself, or just the client bootstrapper helper service? The browser/client should not be attempting to start if you have disabled 'Run Steam when my computer starts.' in the steam client options.
    – Smock
    Feb 4, 2020 at 11:12

2 Answers 2

  1. Press Start
  2. Type "services" into the search box
  3. Press enter
  4. Type "Steam" - now "Steam Client Service" will be highlighted.
  5. Press enter
  6. Set "startup type" to manual.
  7. Press CTRL SHIFT ESC. "Task manager" will appear, and open the "Startup" tab. Look for "Steam Client Bootstrapper", click "disable".
  • 1
    The only required step is the last one, because "Steam Client Service" is set to Manual by default. If is not, something or someone changed the settings.
    – Lemon
    Feb 2, 2020 at 2:14

start by finding task manager in the search bar on windows 10

enter image description here

click more details


click startup

enter image description here

and simply click disable

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .