4

How does Warcraft 3 discover games on the LAN?

I have 3 machines, all with Warcraft 3 1.31 (Not Reforged.) A Mac, A Windows 7 PC and a Windows 10 PC. Any of them can host a lan game just fine, but the windows 10 PC cannot find games hosted by the mac or the windows 7 PC. Even if I turn off the firewall.

What ports and protocols does Warcaft 3 use to find lan games? (Hosting games is well known.)

  • are you able to find the game if u connect through a hotspot, creating by one of your machine? or there might be some setting needed on the router? sometimes also u need to refresh a few times for it to appear. – Tan Jia Ming Feb 4 at 2:00
  • Are they all connected to the router with cable, or do some use wifi/AP/different router? Are they all in the same subnet? – Smock Feb 4 at 10:50
  • They're all on the same wifi. But the mac and windows 7 machine are on the same wifi, so it isn't getting filtered at the network. – Sean McMillan Feb 4 at 14:07
  • have you ensured that the windows machines' network settings are set to "private/work network" instead of "guest/public"? – Yorik Feb 7 at 17:20
  • I think it's set to recognize this network as private. I'm pretty sure I checked that. – Sean McMillan Feb 10 at 17:30
1

Warcraft 3 sends broadcast packets on UDP port 6112. If the machines aren't on the same subnet, or something is not forwarding broadcast packets, then they won't see the game.

| improve this answer | |
  • I guess broadcast on the same port they use for gameplay makes some kind of sense. – Sean McMillan Feb 10 at 17:29
  • There must be more to it than this. I don't know what though. – Sean McMillan Feb 16 at 18:42
  • @SeanMcMillan search for "wc3proxy download" for a tool that may solve your issue. – Foole Feb 16 at 21:40
  • all the responses for that search are "malware explanation/removal", except one for a web proxy. – Sean McMillan Feb 17 at 11:27
0

Based on Some Articles I found on the BattleNet forums, it seems like Blizzard has been trying to faze out LAN for awhile now, perhaps starting with 1.30.2 but definitely now with reforged. If LAN has worked before on the current patch you are on, make sure that your computers can see each other. You can do a simple ping check by checking your ip address with ifconfig on your mac and ipconfig on Windows in a terminal/command prompt and then using the ping command with the IP addresses of your other computers. You can also check in your file systems if you have your computers open to each other on your network.

If you were forced into this patch after not playing for awhile, I'd recommend following the first article to get an older version of the game. You may not have upgraded to reforged but they did get rid of the classic client which did remove LAN. It sounds like you still have the option but people mentioned issues finding games and games force closing while on LAN in the second article so an older version may help.

| improve this answer | |
  • I've already made sure I'm downgraded to the classic 1.31. – Sean McMillan Feb 16 at 18:45
  • That's all well and good but it seems like people were having issues finding LAN games on 1.30.2 and Activision Blizzard seem hellbent on getting rid of LAN altogether. If you can, try rolling back to version 1.27b on all your PCs (this is the version before a newer client was implemented) and see if you can discover your LAN games. – Cloudzzz Feb 18 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.