2

I took over the Covenant and turned it into a settlement. I wanted to renovate the store, and build it as a bar or a room for settlers. I tried clicking the countertop and tried the commands disable and markfordelete. Sometimes I can click on it, but it looks like I'm clicking through the countertop since the object behind it is the one that gets removed. And sometimes I get the error Picked Non Ref AV Object: "".

Is there any way to remove it?

enter image description here

0

2 Answers 2

3

The disable and markfordelete commands don't work for these 'non-referenced AV objects', as they are predefined combinations of separate models, often referred to as combined objects or precombines.

  • You can reposition them using the ModPos <axis> <distance in units> command.
    Doing this along the z-axis is usually the best option, so the command would be setPos z -40, for example.
    There is also a setPos command, but you'll need absolute positions for this (the <distance in units> is <position in coordinates>), and you'll probably need to find the current position using getPos. Note that for the z-position of an object setPos can work equally fine, as most of the Fallout 4 terrain is likely far above z-position 0 anyway.

  • Alternatively, you can disable the bUseCombinedObjects by switching its value to 0 in the Fallout4Custom.ini file (default location: C:\Users\<username>\Documents\My games\Fallout4).
    This will increase render time, especially in heavily cluttered areas, as the predefined models are treated as separate parts once again (but, in case you're planning on using a texture replacer, you might have to change this value anyway).

    Here is a wonderfully in-depth post by user AndrewCX about the AV objects, why there used, and why you shouldn't want to start messing with them.

  • And then, as always, there are mods.
    Like this one, called Spring Cleaning.

1
  • Great! using the command, I'm wondering how do I select the object that I want to reposition if I cant select it? Mar 29, 2020 at 23:21
2

Okay I found another way. I used Creation Kit program.

I checked the basics on how to use it, loaded the Covenant map, removed the countertop and save it as a mod file. Loaded it in the game and now the countertop is removed as I wanted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .