1

I downloaded the game Walking Simulator on Steam but when I tried to play it, it prompted to install Microsoft Visual C++ 2015 Runtime:

Error message

The first time I installed it, the game didn't even start. If I press the play button again, it shows the same error message.

I tried to install the same VC++ 2015 that I downloaded from the Microsoft page and it's the same story. I tried to verify the integrity of the game and it didn't work.

Also, the installation of the component that the game requires doesn't install the 2015 version, but the 2017 version. I'm kind of lost here.

VC installs:

VC installs

Also, does this game need to be installed on the same HDD that Visual C++ is installed on? Because the game is on a different HDD.

Game on Steam:

game

1 Answer 1

1

Try installing the 32-bit version of the 2015 Runtime. The game error message doesn't specify which version, but the version of the Runtime you have installed for 2015 is the 64-Bit version (denoted by x64). Considering it isn't working, I wonder if it is looking for the 32-bit version instead.

You can download the installer file from here. Note that I think it will download two executable files, one called "vc_redist.x64.exe," and one called "vc_redist.x86.exe." You want to run the x86 version to install the 32-bit one.

4
  • hey thanks for the quick follow up yeah i already tried to install from the error msg, let me try to do the install of the x86 ver ill let you guys know whats up Mar 31, 2020 at 1:43
  • it didnt work, 1st tried to install it right away but it wouldnt let me cause it detected the previous install (x64 one), so i uninstalled all of the versions from 2015 and above, and then installing the x86 ver, then run the game but again showed the install error msg, i let it install the version and its installing 2017 x64 ver, so i have no clue how this game works, also i tried changing hd of install and didnt work. maybe it wants the Epic Store install? cause it runs on unreal engine 4 Mar 31, 2020 at 1:54
  • @TamalesRancheros I don't see how where you get the game from matters - have you tried a complete reinstall of the game? That is what I would try next.
    – Timmy Jim
    Mar 31, 2020 at 2:01
  • the game is on Steam, i already tried that. i uninstalled the game and rebooted, then tried to install the game on C:, wich didnt work, and then the same goes for the other drive E: and didnt have luck with that one Mar 31, 2020 at 2:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .