I am running the latest version of iOS Minecraft. Education mode and cheats are enabled.

I've got command block and trying to apply the following command there -

give @p minecraft:written_book{pages:["[\"\",{\"text\":\"The art of rituals is of vital importance to the player.\"}]","{\"text\":\" It is a matter of life and death,\\na road either to safety or to ruin.\"}]","{\"text\":\"Hence it is a subject of inquiry which can on no account be neglected.\"}"title:"Magick Moste Evile",author:Herobrine,display:{Lore:["Of the Horcrux, wickedest of magical inventions, we shall not speak nor give direction —"]}}

But it doesn't work. I get the following error -

Syntax error. Unexpected "minecraft:written_book" at "/give @p >>minecraft:written_book<<{pages:[''["

(some other commands like teleport work well)

What could be wrong here? Are there some limitations applied to iOS version?


1 Answer 1


You can't use the "/give" command to get a "written_book" in Bedrock Edition (Android, iOS, Windows 10, etc.)

Someone posted a bug report to Mojang here: https://bugs.mojang.com/browse/MCPE-34741

I tried the command myself in Windows 10 Bedrock and got the same error you and the person reporting a bug had.

It seems the Bedrock devs didn't feel a need to add the "written_book" item ID yet because they closed the bug report, saying it was a "feature request or a suggestion"

Not the answer you're looking for? Browse other questions tagged .