Logitech G Hub automatically detects games and changes my mouse settings depending on where I'm focused. However, Gears of War 5 is not listed my list of games.

After some digging I came to discover that Gears 5 is installed through the Microsoft Store. The Gears5.exe is in fact under the C:\Program Files\WindowsApps\* folder, which even my admin account doesn't have access to...

I was able to give my local user Full Control of the WindowsApps folder, however, the it threw an error when trying to modify certain files underneath that directory (including the Gears5.exe file).

Is there any way to fix this? I know this is an anti-hack measure, but I just want my damn DPI settings to be controllable through G Hub. It irks me that I don't get full control of my own machine.

enter image description here

2 Answers 2


G hub adds new games every month. I am guessing Gears of 5 wasn't added yet or will not be until future updates. To add it in manually, you have to go to the games and applications screen(the screen you are on in the screenshot) and press "add game". It is on the far right, so you may have to press the arrow to scroll to the right. Press add game and browse for the .exe file for gears of war 5. It will get added and you can customize it.

  • The problem is that the .exe is in a special Windows folder that you can't really take control of. LGHUB would get permission denied because it's in the special folder. I've also tried messing around with changing the permissions but it won't let you become the owner of the .exe files Apr 29, 2020 at 16:33
  • @KolobCanyon Any update? Same issue, when trying to add an exe from local path C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE
    – RazvanR
    Mar 18, 2021 at 12:27
  • 2
    @RazvanR I never figured out how to do this and just gave up. Mar 19, 2021 at 1:52

I found this worked for me (to get Logitech G Hub to access the WindowsApps folder): https://forums.forzamotorsport.net/turn10_postsm780252_How-to-find-the-game--exe-shortcut-to-write-in-Logitech-Gaming-Software.aspx#post_780252

Run PowerShell as administrator then run:

cd "C:\Program Files"
takeown /F WindowsApps
icacls WindowsApps /grant Administrators:F
icacls WindowsApps /grant Administrators:F /Τ
icacls WindowsApps /setowner "NT Service\TrustedInstaller"

Edit: I wasn't specifically targeting the Gears of War .exe, just another .exe within the WindowsApps folder

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .