I have the Xbox 360 version of Saints Row 2. I have successfully played co-op with another friend in the past where we both only had the Unkut DLC. A different friend of mine has all 3 DLC packs (Unkut, Corporate Warfare, and Ultor Exposed), and we tried to play co-op last night but we both kept receiving this error, even after I bought the rest of the DLC:

You do not have the same downloadable content as the host

But... I do. We both tried hosting to no avail. Is there any fix for this?

  • I think that you should just redownload it again just to be safe
    – user49059
    Commented May 24, 2013 at 20:52

2 Answers 2


Both redownload all content - it maybe some of it became corrupt.

I've had this personally happen in the past - in the storage area it also had a strange "failed download" or some sort of item stored there. This doesn't need deleting but may help - its left over when a download has failed previously.

Also, just in case once you've downloaded all the content, load the game in normal "single player" mode, just to make sure your save file has updated with all the new content.

  • @FAE Did this work? Is there some way to improve upon this answer?
    – skovacs1
    Commented Apr 26, 2012 at 9:15

You can't play saints row 1, 2, or 3 together on the same console. You have to have the same console, update for the game, and it can't be on the same t.v. I think it sucks for that reason, but you can't have a split screen on the game.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .