3

For at least a couple of years now I get SUPER strange behavior in Minecraft. I can connect freely to 99.9% of servers and play them without any issues and with a fast connection. Every time I or friends buy a host(We currently have a host at ExtraVM) I cannot connect to it(Only it, servers like Hypixel, Cubecraft and Mineplex work perfectly). They can play it without any issues, they connect immediately and play with good ping but I can't even connect.

When I join the server it says Loading terrain... for ~15 seconds or so and then Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host. If I try to connect for 10 minutes or so it eventually connects but if I get disconnected, well I need to try for 10 minutes again.

I've tried EVERYTHING! I made new rules on my Firewall, changed DNS servers and even reinstalled Minecraft but it seems it's not a computer problem as with another PC from the same network it has issues as well. When trying to connect with a hotspot I can connect and play but I do not have an unlimited plan so I cannot allow myself. I even tried opening Wireshark and sniffing the packets, it seems the Minecraft client tries to send packets to the host and doesn't get any back so it retransmits the packets until it kicks the error mentioned above(See image).

I have a 40mbps plan and in other games I get 70-90 ping so I don't think the internet speed is an issue.

If anyone has any ideas I can try PLEASE tell me.

Cheers!

The server I try connecting to Wireshark sniffing

0
1

Since you can connect to the server via hotspot, I would assume this is not a server side issue. I'm guessing this is a local issue.

Here's the things I would try:

  1. Temporarily turn off the firewall on your computer and try to connect. If you are able to connect, your computer's firewall is the issue. Be sure to turn your firewall back on.

  2. Temporarily turn off your router's firewall and try to connect. If you can connect, your router's firewall is causing the issues. Be sure to turn your firewall back on.

  3. There's a port forwarding issue. Check and set the ports forwarding rules for your router. Minecraft for PC uses ports:

    • TCP: 25565
    • UDP: 19132-19133,25565
  4. Verify you are running the latest version of Java.

  5. Your modem may be also acting as a router:

Your modem might be acting as a router as well. If you switch ISP's or upgrade your connection to the Internet, you may get issued a modem/router combination (which might explain why it worked in the past). You can verify this by looking for the WAN IP of your router. If it's a private IP, you'll need to log into the modem/router your ISP issued to you, and configure port forwarding to the WAN IP of your router.

source for #5: https://minecraft.gamepedia.com/Tutorials/Setting_up_a_server#FAQ_.28frequently_asked_questions.29

Another thing you can try is to contact the hosting company about the problem. From what I can see you have done your research, tried basic troubleshooting, and have a good knowledge base about networking. They may be able to give you some additional ideas.

2
  • Thank you for answering, tried option 1 and didn't succeed, about option 2 I do not have a firewall on my D-LINK router as stated in the D-LINK website so I tried setting DMZ instead but no success and I did option 3 as well and nothing worked. But thank you for trying to help :D – ofido Apr 9 '20 at 9:21
  • 1
    Thank you again for answering but 4 and 5 didn't work as well, I might contact my ISP because I think that's a problem on their end as other private servers hosts have the exact same issues -_- Tho more answers are also welcome :D – ofido Apr 10 '20 at 16:09
1

Well, 2.5 months after I asked the question I still don't have a good explanation or answer to this problem.

The way this problem got fixed for me is by moving ISP. Before I moved I had a NAT without a static IP and every port I tried opening on it didn't work. Now I do have a static IP and I can open ports on it. I'm 90% sure the problem was with my ISP as that is the only thing that fixed it. (I do have the same router, the same ports I tried opening in the past that were still "open" on the router and everything)

So anyone experiencing this as well, I'm sorry, there is nothing you can do except calling your ISP and asking them...

0

Try connecting to other servers that run on the same host. Then also check in with the server owner to ensure it's not corrupt. Run a virus scan on your PC as well. Some viruses try to lock connections to servers that may try to intercept the virus's work. Also, check if everything is up-to-date. Reinstalling minecraft might be something you should consider. Check the FAQ of the server host and check if there is a solution too!

As a last resort, reinstall your OS.

1
  • It doesn't happen with this host only, many servers we created before from different hosts as well have the same issue for me. Though large public servers work perfectly. The server is working for others and I didn't find any viruses(Even checked with process explorer) I have everything up-to-date and I already reinstalled Minecraft. And about reinstalling the OS, I might do that in the future though I'm 98% sure its not a PC related problam as I mentioned in my question that other PCs on the network are the same. But thank you for your time :D – ofido Apr 15 '20 at 10:36
0

Check to make sure you haven't blacklisted any websites that are crucial to Minecraft on your router.

1
  • I don't have any blacklisted websites or IPs. – ofido Apr 15 '20 at 10:35
0

thats an isp problem, same as me, i tried any ways (firewall, router firewall, & etc..) the isp blocking the port to forwarded, and trying to block your packets (what firewall does in ping) then you will see the connection forcibly closed by Remote host means that your remote host firewall (isp) forced the connection to timed out

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.