This question is all over the place, but I have found no answers to help me solve it!

I set up a Minecraft Bedrock server (version on an Ubuntu 18.04 VM running on VirtualBox (hosted on my Windows 10 desktop), and have forwarded UDP port 19132 in my router to the VM. (Note: ufw is currently disabled in Ubuntu).

I can happily connect to it from within the LAN (ie. from my Windows 10 computer, using the LAN IP of the server), but any attempt to connect to it via my public IP address fails with the usual 'Unable to connect to world' error message.

Running tcpdump on the VM and watching UDP port 19132, I can see a steady trickle of packets reaching the VM while I have the Minecraft app open and am in the Servers list with my server added at the bottom (using the public rather than private IP), indicating the client is polling the server. The client shows the server as offline though. Similarly, when I try to connect, I see an increased flow of packets arriving and yet no connection. I know my port forwarding is set up correctly (according to the instructions provided), but still no joy.

To be certain, I have also tried connecting to the server using an iPad outside the LAN - no dice.

Most interesting clue I have found so far was the commentary in this bug report: https://bugs.mojang.com/browse/BDS-85

Per the comments there, I tried creating a 'minecraft' user with home directory /opt/minecraft and running the server from there. Sadly, this had no impact.

UPDATE: I have also tried running the server directly on my Windows 10 host now also. Same behaviour results here also (with router port forwarding rule updated to the new host IP).

  • Were you ever able to resolve this issue? I have the exact same issue. And I also tested it on a Windows 10 host and had the same exact issue. I can connect via LAN but not WAN. Commented Mar 1, 2022 at 4:40
  • I think I got this running in a different network environment eventually, although it was only used once or twice and not since, so I don't recall what the answer was, sorry. :-(
    – John Rix
    Commented Mar 8, 2022 at 16:02

4 Answers 4


You also have to forward port 25565. I have no idea why this works, but it does.

  • 2
    Seems like the OP was using port 19132, so forwarding 25565 probably won't work.
    – Timmy Jim
    Commented Aug 8, 2021 at 17:32

I've been fighting the same problem for the last few days. Finally I seem to have found the solution by:

  1. Forwarding the VM IP address (probably silly but I initially fwd the NAS that runs the VM
  2. Fwd ports 19131/32/33. My router supports fwd of both TCP and UDP

Later I will try to figure out which of the 3 ports are actually needed and whether I need to fwd both TCP and UDP requests. But for now happy that it is working!

  • Doesn't work either for me.
    – Mike
    Commented Mar 19, 2022 at 4:19

This is likely a result of most routers blocking foreign connections that were not initiated by you. Check your router settings.


For some reasons Ubuntu 18.04 on virtualbox doesn't have default route to gateway after installation, while in the same time it knows how to go to the Internet when you want to ping google.com, for example :) Adding default route solved issue for me:

$ sudo ip route add default via

where is IP of your gateway in local network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .