-1

I have forge 1.15.2 and some mods for it and I found another mod that's for 1.14.4. Do I need to download forge 1.14.4 to be able to use this mod or can I use the forge that I have now?

2

Older mods are not compatible with newer versions of Forge. They're only able to be ran with the version of the game they were made for.

This is because the code the mod uses only fits with the code of that exact Minecraft version. When Minecraft updates, the code changes, rendering the mod unusable for that new version.

| improve this answer | |
  • Ah that makes total sense. Thank you MalO♡ – iIvy Apr 22 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.