2

I'm trying to swap out the stock 1TB HD in my PS4 Pro, for a newly-purchased 1TB SSD. This should be really straight forward but I'm having nothing but problems, seemingly centered around my USB stick(s).

I have a 4GB stick that I pretty much only use for the PS4. It's empty except for a folder called "PS4" and and inside that, a folder called "UPDATE". Inside the update folder I put the full fresh-install update file (the 1GB one). Swapped out the HD and booted into safe mode, and I have gotten 3 different errors at different times:

  1. USB device needs to be formatted as ex-FAT (I seemed to be getting this because my external USB HD was still connected. Disconnecting it made this error go away).
  2. Update file not found
  3. USB device is not connected

I have reformatted the USB drive many times under Windows 10 making sure it's MBR, and have tried both Fat32 and exFat filesystems. I also tried another 16GB USB stick that was exFat already and had some PC stuff on it. I added the PS4/UPDATE path, and dropped in the update file. No luck with that one either. I've also tried both front USB ports.

I have also freshly formatted the SSD drive as exFat, without assigning a drive letter in Windows, but it didn't help.

The main recurring error now, is that the update file is not found The USB storage device is not connected (SU-41333-4). It's clearly there, the paths are right, everything seems fine that I can see... so what's the problem here?

2

So it dawned on me, that I kept being told that the "USB Storage Device Is Unavailable". Usually "Storage Device" refers to an external HD, connected to the rear port on the console. For the hell of it I put the USB key in the rear port... and immediately it worked FINE where it would not work in either of the front ports!

To be clear both front ports work fine, they charge controllers, accept USB keys for media, etc. But for whatever reason, in Safe Mode, they won't work for a USB stick (or the rear is somehow overriding). So if this ever happens to you, dear stranger on the interwebz... try the rear port!

| improve this answer | |
  • Very strange, this wasn't the case on the original PS4, but it seems the Pro is more like a PC in that regard. Good find! – Kaizerwolf May 3 at 12:43
  • 1
    Yeah I was shocked. I've always done everything with USB keys in the front port, but this is the first time I've ever fully initialized the internal drive so... maybe that's different? Go figure! – JVC May 3 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.