My problem is a rather simple one:
When running Deus Ex: GOTY on Steam, the game crashes when in the Battery Park level, near the vent section, leaving a critical error message:

Critical Error! Runaway loop detected

I'm running the game on Linux through Proton 4.11.
I tried running Deus Ex in safe mode, but the game still crashed.

1 Answer 1


There is a fix here:

  • Start the game using the -hax0r parameter in the launch options. This enables cheat mode.
  • In-game, using the console, press t, remove the say that's entered by default on a new command line, and type playersonly. This will freeze all other entities, only to temporarily prevent them from running right into problems again, giving you more time to terminate the buggy entity.
  • Type killall deusex.terrorist to eliminate the faulty entities in your current game.
  • Type playersonly again to resume normal play.

Alternatively, try out the replacement executable (neatly named Deus Exe) from that same link.

  • Nope. I typed "playersonly" when loading into the save and it still crashed, while I was typing "killall deusex.terrorist19".
    – Psionikal
    May 6, 2020 at 14:24
  • Now I tried killall deusex.terrorist after playersonly and the game still crashed. I can confirm this time I was fast enough.
    – Psionikal
    May 6, 2020 at 14:30
  • Should I expect something to pop up when I successfully type in a command?
    – Psionikal
    May 6, 2020 at 14:32
  • I've already tried it multiple times, but none worked, they all returned the same error.
    – Psionikal
    May 6, 2020 at 16:07
  • 1
    After some quick testing, turned out I had to do the "playersonly" trick after replacing the installer. Problem solved, thanks for the support.
    – Psionikal
    May 6, 2020 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .