1

I am trying to open up a second port, and I tried following the MineOS Wiki but I don’t know where I enter all of the command lines it gives me. I tried entering them in a shell under the MineOS jail in the FreeNAS WebUI, but that didn’t work. I also tried following the wiki on how to setup root login so I can ssh with PuTTY, but I don’t know where to enter “service sshd restart” after I configure it. Even if I could have figured that out, I still don’t know which IP address I’m supposed to use to ssh. If I just used my regular IP for the entire server device itself, then what user and password would I use if I need to run the Iptable commands?

5
  • I don't know half the technologies you're using, but here are two general comments: 1. Did you actually mean to type "jail"? 2. "service sshd restart” is a console command that works e.g. on Debian-based Linux distributions. There should be a program called something with "console" or "terminal" or "command prompt", use that to enter the command. – Fabian Röling May 8 '20 at 15:40
  • 1, Yes, I meant to say jail. Every plugin on FreeNAS has a jail, and I found that I could open a terminal/shell under that specific one for MineOS. 2, I tried to enter "service sshd restart" into the terminal/shell for the MineOS jail, and the FreeNAS one, but both say "Cannot 'restart' sshd. Set sshd_enable to YES in etc/rc.config or use 'onerestart' instead of 'restart'." I don't know where the rc.config is located, and replacing "restart" with "onerestart" doesn't fix the issue. – Zachary Gonzalez May 8 '20 at 18:05
  • Your home folder (where the console usually starts) is /home/yourNameHere, that file is in /etc. And really, it says "try onerestart instead" even if you did use "onerestart"? That's a bug then, but I don't know if just the error message is wrong or the entire behaviour. – Fabian Röling May 8 '20 at 19:07
  • Well, if there is a bug in that, do you know where I would at least enter the command lines on the MineOS Wiki? (minecraft.codeemo.com/mineoswiki/index.php?title=Iptables) Even if I'm supposed to enter the commands on the wiki in PuTTY, which IP address am I suppose to ssh with? Using the IP for the MineOS plugin doesn't work. EDIT: When I try to use the Iptable commands in the shell for either the MineOS plugin or FreeNAS itself (in the FreeNAS WebUI), it says "iptables: Command not found." – Zachary Gonzalez May 8 '20 at 19:39
  • As I said, I don't really know the programs and services to use, I just recognised some Linux commands and gave general tips. Now someone else needs to take over. – Fabian Röling May 9 '20 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.