I've been playing Gears Tactics on Windows 10 via Xbox Game Pass for the last few days. Everything was working fine until it tried to install an update yesterday. The download hung at 246MB out of 2.8GB, with an error code 0x800704c6, message "couldn't connect to the service". I cancelled it, which uninstalled the entire game. When I tried to reinstall, it hung again, at the same place (but now out of a 28GB download).

Things I've tried:

  • Reboot the machine
  • Repair/reset/uninstall/reinstall the Xbox Beta app
  • Run the Windows Store troubleshooter
  • Run wsreset as admin
  • Run sfc /scannow as admin
  • Reboot with a clean start (no services/startup apps loaded)
  • Install from the Windows Store
  • Install from the Xbox Beta app

Is there anything else I can do, short of nuking and reinstalling the OS entirely?

I can install other XGP games (just tried and succeeded with Moving Out), so the problem looks to be specific to this game.

1 Answer 1


Using a VPN has fixed the problem, at least for now. I installed the free trial version of ProtonVPN, and GT downloaded successfully via the Xbox Beta app.

One wart is that you have to connect to a VPN server in the same region as your Xbox region. The free ProtonVPN connects you to a random server AFAIK, so you may have to keep trying until you get one that works.

Edit: I ran into the same problem when installing BattleTech. ProtonVPN unblocked me again, but this time, it worked despite connecting to a server outside my region. So that specific requirement may not be necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .