0

I've looked at the patch notes, selected the beta and updated my game, it shows in my Steam library: enter image description here However, when I start the game and a greenskin campaign it's the old version. This is especially easy to detect by looking at the Waaagh! status.

0

Just to try I opted in to the 1.9.0_(live_build), this has made the new campaign and DLC available to me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.