0

I tried to install Steam on my PC today, and it didn't work due to the "Failed to load Steamui.dll" error.
Of course, I tried most of the solutions on the web, such as deleting and re-installing Steam, manually removing the Steamui.dll file and/or replacing it with one on the web, but these solutions didn't work. Every time I try any of these fixes, the same error occurs.
How can I fix this?

There are no Korean-named folders in the way, if you were wondering.

I also noticed something strange: when I was trying the fix where you delete the Steamui.dll and Libswscale-3.dll files, I noticed that my Steam installation didn't have the Libswscale-3.dll, but a Libswscale-4.dll, instead. I'm not sure if this is causing the problem, but I think this may be of importance. I didn't tamper with it just in case it would cause even more problems.

In the image below are the contents of my Steam's DLL folder.
Ignore the DLL named originalsteamui - it was what I was tampering with.

Ignore the "originalsteamui", that's the steamui that steam installed itself but I renamed it so I wouldn't have to delete it

  • Hi Hu sh, it would be easier if you just mention the current state of affairs, and not the things you were looking for and then found. Also: what's the premise here? You tried reinstalling something which is Steam, I presume, but why did you do so, and why are you stuck at trying? It would also be a lot easier if you describe what we're supposed to see in the screenshots, so it's easier to follow your already muddled story. – Joachim May 24 at 1:19
  • Oop sorry, let me make it clearer. As you can probably tell, I'm not the most mature... – Hu sh May 24 at 3:26
  • Hope this edit cleaned up any confusions! – Hu sh May 24 at 3:31
  • Yes, thank you. I hope my answer will help you. – Joachim May 24 at 10:14
0
  • In most cases it's practical to start troubleshooting a malfunctioning program by running it as an administrator of your system.
    This is likely not the cause here, but it can help speeding up the process.

  • Temporarily disable any third-party firewall, anti-virus software (Windows Defender usually plays nice, for a change), or other intrusive software, and try restarting Steam.
    Take caution, as this will also temporarily leave your system vulnerable, so be sure to re-enable directly after a problem is fixed (that is: disable only during that window of restarting Steam).

  • Try deleting that Libswscale-4.dll file: it surely is a newer version of Libswscale-3.dll, and, in any case, if Steam is missing files, it will redownload them.

  • There are a few more fixes explicitly for your case mentioned in this Steam Community thread, most successful of which seem to be (or seems to be a combination of) the following steps [edited slightly for readability]:

    All you have to do is restart your computer in Safe Mode. Delete all of your Steam files other than the AppData folder and the Steam.exe file. Double click Steam.exe and it should successfully install the update.

    and

    Fastest way, instead of redownloading after deleting the files in Safe Mode, is to add the following parameters to your Steam shortcut: -clientbeta client_candidate (e.g. "C:\Program Files\Steam\Steam.exe" -clientbeta client_candidate).

    Now, before you try this in Safe Mode, I suggest deleting the mentioned files - as administrator - in the normal Windows mode, creating a shortcut, adding those parameters, and running it - as administrator. If that doesn't work, you can always fiddle around in Safe Mode.

| improve this answer | |
  • Thanks for the huge amount of help! I'll try them out and tell you the results. – Hu sh May 24 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.