I recently bought and installed Rust along with Steam onto my computer (running Ubuntu 16.04 LTS and now 18.04 LTS). After downloading, I tried to run Rust first from Steam and then from the desktop icon, but to no avail. Everytime I click PLAY a window pops up saying Preparing to launch Rust..., which then closes and supposedly stops (the STOP button turns back to PLAY). I found my way to the output_log.txt file to see if there were any issues, and have pasted to content below.

Found path: /home/main/.local/share/Steam/steamapps/common/Rust/rust
Mono path[0] = '/home/main/.local/share/Steam/steamapps/common/Rust/rust_Data/Managed'
Mono config path = '/home/main/.local/share/Steam/steamapps/common/Rust/rust_Data/MonoBleedingEdge/etc'
Preloaded 'ScreenSelector.so'
Preloaded 'libRakNet.so'
Preloaded 'libRenderer.so'
Preloaded 'libRustNative.so'
Preloaded 'libeac_server.so'
Preloaded 'libeasyanticheat.so'
Preloaded 'libsteam_api.so' 
Unable to preload the following plugins:
Display 0 '0': 1366x768 (primary device).
Desktop is 1366 x 768 @ 60 Hz
Vulkan detection: 0
No supported renderers found, exiting

(Filename: ./PlatformDependent/LinuxStandalone/main.cpp Line: 639)

eac_server.so [x64] :: OnLoad()
eac_server.so [x64] :: OnUnload()

I assume the error is that it didn't preload libRenderer.so and libRustNative.so, but when I tried to find a solution for this I couldn't. If this is the issue, does anyone know how to fix it, or how to preload the files another way?

EDIT: I'm not trying to run a server or anything fancy, just the base game.

EDIT: I figure more information can't hurt. This is the console output when trying to run the game:

ExecuteSteamURL: "steam://rungameid/252490"
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to ProcessingInstallScript with ""
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to SynchronizingCloud with ""
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to CreatingProcess with ""
GameAction [AppID 252490, ActionID 3] : LaunchApp waiting for user response to CreatingProcess ""
GameAction [AppID 252490, ActionID 3] : LaunchApp continues with user response "CreatingProcess"
Game update: AppID 252490 "", ProcID 20033, IP
ERROR: ld.so: object '/home/main/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/home/main/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
CreateDirectory '' failed:  (current dir: )
Starting app 252490
>>> Adding process 20033 for game ID 252490
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to WaitingGameWindow with ""
>>> Adding process 20034 for game ID 252490
>>> Adding process 20035 for game ID 252490
GameAction [AppID 252490, ActionID 3] : LaunchApp changed task to Completed with ""
Game removed: AppID 252490 "", ProcID 20033 
Uploaded AppInterfaceStats to Steam
Exiting app 252490
No cached sticky mapping in ActivateActionSet.

3 Answers 3


The error looks pretty straightforward.

Vulkan detection: 0
No supported renderers found, exiting

This may mean either that your Graphics card has no vulkan driver support (generally because it is too old to be supported), or simply that you don't have the necessary driver/support packages installed.

(An OpenGL renderer hasn't been supported since some time early 2019, according to a youtube video I found.)

The output of the command vulkaninfo could give more info about your vulkan support. (If it doesn't exist, install the vulkan-tools or vulkan-utils package to get it.)

If that command doesn't exit with an error, such as VK_ERROR_INITIALIZATION_FAILED, then there is a chance you can get it to work.

And probably a simple internet search will already tell you whether your graphics card should have Vulkan support.

Bear in mind that, even if you can solve the renderer issue, the game may not work. There is the possibility that the EAC Anti-Cheat will kick you out, since they have stopped their Linux support (at least for this title).

Or, since Facepunch Studios themselves have stopped supporting Linux, there is the chance that it won't work simply because the Unity engine shipped with the Linux build has issues (Perhaps they still drop updates for Linux unofficially, perhaps they don't - I have no clue.) or they might even actively kick linux clients, since no adequate cheat protection might negatively influence the playerbase as a whole (dev reddit post).


Linux and Mac were using a rather old version of OpenGL that didn't support many of the optimizations we were using on Windows and would regularly break shaders. In order to make future development easier for us and give the two people playing on those platforms a slightly better experience we decided to move Linux to Vulkan and Mac to Metal. This means that if you're on Linux you should install the absolute latest graphics drivers you can get your hands on and ensure that you are no longer adding the "-force-opengl" startup parameter since that will break the game. You can also give Vulkan a try on Windows with the "-force-vulkan" startup parameter, but on most graphics drivers there are still some issues so we generally recommend staying on DirectX for now.
Facepunch said on there site.


The combination of the original and your edit seems to have a small trail to an answer that sounds like an arduous journey:

In the original it has "eacserver [x64]". This implies you're running a 64-bit install. Also that Easy Anti-Cheat's server is running, but IDK if that happens when running the game itself or not -- are you sure you're launching the game?

In the edit it has "(wrong ELF class: ELFCLASS32)". ELF = Executable and Linkable Format. The 32 implies they're 32-bit, but the system wants 64-bit.

Relevant short answer on Ubuntu Stack Exchange under "12.04 - unable to load shared object wrong ELF class: ELFCLASS32". Too Link; DR: Can't run 32-bit libs on 64-bit system.

Finally, this Reddit post should help you install those missing dependencies. This ArchLinux Steam troubleshooting guide has a couple more complex scripts to find missing dependencies that could be useful, but they're not as easily understood without lots more reading documentation and experimentation than the short options.

  • The "wrong ELF class" error happens regularly on many linux steam games which try to aggressively preload .so lib files that aren't really necessary (like the gameoverlayrenderer.so here). That error message has no bearing on the issue.
    – nyov
    Jun 10, 2020 at 0:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .