I made a custom model for diamond ore and applied it to a resource pack. However, when I applied said resource pack in-game and placed blocks around the diamond ore certain sides of the diamond ore model got shadowed out. I am pretty sure that this is because minecraft doesn't think that those sides of the model should be rendered, because technically that side of the model has a block on it, but if there is a way around this I would like to know.

How the ores look in game: How the ores look in-game

How they are supposed to look (achieved by setting gamma to 1000 in options.txt): enter image description here

1 Answer 1


If you set the cullface value for all faces to the appropriate side, lighting issues should be fixed.


cullface: Specifies whether a face does not need to be rendered when there is a block touching it in the specified position. The position can be: down, up, north, south, west, or east. It also determines the side of the block to use the light level from for lighting the face, and if unset, defaults to the side. bottom may also be used in the latest versions instead of down, despite appearing only once in the actual game assets.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .