1

My friend and I used to play a lot of minecraft. Today when he came over we decided to play some. I created a world, opened it to lan, but it just wouldn't show up. We even tried direct connect with our ip address and port, but recieved the error: "java.net.SocketException: network is unreachable, no further information."

Here's what we've tried:

Checked minecraft in windows firewall, which we've already done before. (It fixed the world not showing up before, but now even if it's checked the world isn't there)

Direct connect.

Using the ping command in the commandline. We both ran ipconfig and tried to ping each other, which was successful, which probably means it's a minecraft or firewall problem.

4
  • 7
    Possible duplicate of Why isn't my Minecraft LAN server working?
    – pppery
    Feb 27 at 3:36
  • @pppery or mods: At least maybe merge the information here? There is no mention of the SocketException error in the duplicate, and uninstalling Hamachi seems like a convenient tip.
    – Joachim
    Feb 27 at 8:52
  • 1
    @Joachim Feel free to raise a mod flag for merger if you feel a merger is desirable
    – pppery
    Feb 27 at 17:35
  • @pppery I can do that, but my point was more that I'm wondering whether this is actually a duplicate, as both those things I mentioned are not duplicated in the question you have linked. Obviously you think it is a dupe, so this was more meant as a signal to others :)
    – Joachim
    Feb 27 at 17:58

2 Answers 2

0
  • you should try with an other mincraft version like 1.9.3 or some thing like that.
  • if it persists try with a completly different version like latest 1.15.
  • then, if it continues it clearly means that one of the two computers (or both) is not capable of connecting to the other. in order to verify this statement, try connecting on an external server on each computer. if both can't it might be a problem related to your router. if one or the other can't, it means that this computer either struggle to connect properly to your local network that may cause issues in routing its requests or that your firewall is effectivly doing Something wrong. if you can both connect to a distant server, i Don't know what that mean, it can be a lot of thing then (like your computer can't host etc.).

or you can try to download a vanilla server of 1.9.4 to see if it continues to fail.

Hope this list of todo help in your problem solving. i would like to keep in touch with this problem because it may not affect only you.

0

Uninstalling Hamachi did the trick.

Not the answer you're looking for? Browse other questions tagged .